Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
search inside all forums
USB-ML-UNIVERSAL-FX (Rev. B) not working on Win10 Pro
Bill E. Feb 26, 2020 at 08:42 PM (20:42 hours)
Staff: Johnny N.

  • Hello.  I have read various forum entries related to problems with Win10 but none of the solutions has helped get my unit working.

    The message in Device Manager for "USB Multilink 2.0" says: "Windows cannot verify the digital signature for the drivers required for this device. A recent hardware or software change might have installed a file that is signed incorrectly or damaged, or that might be malicious software from an unknown source. (Code 52)"

    I have no problem using this ML-FX on Win7 Pro.

    I have tried uninstalling and reinstalling drivers but that has not helped.

    Win10 Pro (64-bit): 1909 (OS build: 18363.535)
    32G Ram, i7-9750H CPU
    pemicrowindrvr Driver: (1/4/2017)
    USB Multilink 2.0 Driver: (11/30/2017)

    Win7 Pro (64-bit): Ver 6.1 (Build 7601: Service Pack 1)
    8G Ram, i5-3210M CPU
    WinDriver Driver: (10/26/2014)
    USB Multilink 2.0 Driver: (8/29/2012)




    • Bill,

      I have a few suggestions for the error message regarding the digital signature for the USB drivers.

      1) Uninstall Jungo->pemicrowindrvr and Jungo->USB Multilink 2.0 from the Device Manager screen. You should check the "Delete the Driver files for this device". Manually erase all of the driver files from your Windows folder and reinstall the driver package as a local Administrator. Our driver test displays the list of files that should be erased. Here is the download link:

      2) If Jungo->USB Multilink 2.0 still shows the same error message, uninstall it again. Then select Action -> Scan for hardware changes which will force it to reinstall USB Multilink 2.0 again.

      3) Finally, it is possible your Windows is missing or has outdated root certificates. The certificate that our driver installer is signed with is verified against the root certificates that are installed on your PC. This is the process that Windows uses to validate the authenticity of our files. Do you have internet access on this PC? Generally the certificates are updated when you run Windows Update. I would ask your IT department to run Windows Update and look for any updates and/or service packs related to certificates or digital signatures.

      PEmicro Support

      • Thanks Johnny.

        I uninstalled the drivers and ran the driver test tool. I deleted the detected files and then re-installed the drivers using 'multilink_universal-install.exe'. The ML-FX is now detected properly and connects to the Kinetis K20 part. I don't know why it didn't work before but probably due to the lingering driver files.



        Out of curiosity: What is 'C:\Windows]sysnative]drivers]pemicrowindrv.sys [Version 12.03]'? This showed up in the driver test app but that path does not exist on my system.

Add comment

   Want to comment? Please login or create a new PEmicro account.

© 2020 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement