Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
search inside all forums
Trouble getting the USB Multilink FX to connect in PROG12Z (Windows 10 Surface Pro)
marty w. Jan 7, 2020 at 04:29 PM (16:29 hours)
Staff: Takao Y.

  • I have loaded the PROG12Z software and activated it on my laptop, but when I try to connect the USB Multilink FX flash programmer, it does not see the USB connection, and does not recv. any power.


  • Greetings,

    Which version of PROG12Z are you using? And which multilink universal FX revision are you using? You may require a new PROG12Z software to get it working on the latest operating systems.


    • Thanks for getting back on my question.

      I just bought the software last week. I downloaded it from PE Micro directly.

      "USB Multilink Universal FX High-Speed Debug Probe for ARMĀ® devices and 8/16/32 bit devices" also bought last week from PE Micro

      I tried uninstalling it and re-installing it, and tried to update the drivers, but I I had the same results.

  • Greetings,

    Try installing the multilink universal resource CD and use the PE Firmware Config utility within this resource CD to determine if your computer can see your multilink device:


    • I did not get a CD with the programmer-can I get one online?

  • Greetings,

    That link I posted is the online one. Please download it.


Add comment

   Want to comment? Please login or create a new PEmicro account.

© 2020 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement