Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
search inside all forums
Programming 68HC912DG128A with Multilink
Diego B. Nov 7, 2019 at 10:27 AM (10:27 hours)
Staff: Takao Y.

  • Hi all,

    I have been trying to program a 68HC912DG128A device with a Multilink Universal and Prog12z program.

    After the connection is done with the connection manager, I have tried to choose the right module algorithm, however I do not know which one of the all Freescale_912DG128A_XXXXXXXXXXX algorithm should I choose.

    How do I know which one is the right option for my device?




  • Greetings,

    Open each of the algorithms in a text editor. That is how you can figure out what each one means. Impossible to explain each one within a file name.

    There's EEPROM, Shadow Word, and Pflash. PFLASH is 128K, but it can be broken down into 4 separate 32K pages.

    So which one do you need? That is up to you to decide depending on the binary file you have.

    Takao Yamada

  • Thank you Takao for your answer. 

    I was checking the binary file(.s19) that I have and the algorithms in order to figure which one is the right and I have found the following:
    In the Freescale_912DG128A_XXXXXXXXXX algorithms, the data is defined as "S1", which means that the addresses are 16-bits. However, in my binary file, the data is define as "S2", which means the addresses are 24-bits.

    I have tried to program with that binary file(.s19) and some algorithms and I have always obtained the same message at the status window:

    Checking range of S records. -
    Ending address is no in module or is less than starting address. Invalid address detected.
    Invalid addresses in srecord block from $00078000 to $0007801F.

    After that appears a pop-up which says:
    All S record addresses not in range or module.
    Continue ? (Yes/No)

    Whatever you choose, yes or no, the status window says:
    Programming Address $ No data to program.
    .Error during programming.

    With the previous messages and the fact that our MCU is 16-bit, it seems like our binary file is not properly coded. Does it makes sense to you?



  • Greetings,

    Sorry for the delayed response. The S1 and S2 definitions will not cause the error you are seeing. As long as the files were generated from a compiler, then our tools will be able to distinguish the differences between S1 vs S2 vs any other s-record format.

    Any update on this? Were you able to resolve this issue?

    Takao Yamada

Add comment

   Want to comment? Please login or create a new PEmicro account.

© 2020 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement