Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
search inside all forums
Not updating firmware version 5.77
Rajasekaran N. Oct 31, 2019 at 09:54 AM (09:54 hours)
Staff: Gilbert Y.

  • Hi PE Micro team,

    Im using Multilink universal device with Rev D, its detecting with my computer but not able to connect with other device. and showing Firmware update failed for version 5.77.
    Also the firmware updater result shows the latest version is up to date only.
    kindly give me the link to download firmware 5.77 drivers or help to solve this..


    • Hello,

      What version of Windows are you using with this computer? If you are using Windows 10, have you updated your PEmicro drivers according to our FAQ?

      If you have already done that, you can download our latest Multilink software at the below link. At this link, you can download the latest Multilink firmwares through the link "USB Multilink Universal (and FX) Resource CD"

      Please let me know if you have any other questions.

      Gilbert Y.

      • Hi,. 
        I'm using windows 7, 32 bit system. And it is latest updated only..

        • What software do you mean is the latest update?

          The current firmware version for Multilink Universal is v10.29 if you install the software linked above. The "Universal Multilink Firmware Update and Architecture Selection Utility" will be version v10.17.

          • I mean my computer windows 7 OS is updated one.
            I used the above link and installed the multilink universal, but I getting same result only.
            the firmware updater is selecting by auto mode: usbmlfsufbdmens.1018 result:success.
            After connecting to the controller through Hiwave application it is showing current firmware :1..1 Update firmware:5.77 and flash erase failed result:$8882, Firmware update failed..

            • Hi PE micro Team,
              awaiting for your reply to solve this issue..


              • Have you installed the patch for CodeWarrior Classic? 


              • Did installing the patches resolve this issue?

                • No still the same result.. showing Firmware update failed.
                  I have using Multilink Rev. A, B, C devices in my laptop and it is working fine. The Rev. D is detecting but result showing is Firmware update failed. Kindly send me what are the files/application/drivers to be installed for this Rev. D Multilink.


                  • I see. I just saw that you actually have a support request open with us already, so I will continue to work with you and our other engineer through that.

Add comment

   Want to comment? Please login or create a new PEmicro account.

© 2020 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement