Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
search inside all forums
USB Multilink Universal Does Not Connect
David K. Sep 20, 2019 at 12:23 PM (12:23 hours)
Staff: Takao Y.

  • Hi,

    I was previously running a USB BDM Multilink Interface Rev C (1008) for RS08-HCS08 HC(S)12(X) - ColdFire V1 (Part# USB-ML-12E). This product is obviously obsolete. I purchased a new USB Multilink Universal (Part# USB-ML-Universal) to replace the old unit.

    The IDE I am using is the CodeWarrior for MCU Version 10.7, Build ID 160721 to make program modifications to an MC9S08LC60CLK micro-controller from Freescale (now NXP).

    Everything was working perfectly with the previous setup. I simply upgraded to the new USB Multilink Universal and now I can not connect to the interface hardware. The P&E Connection Assistant indicates I am using "USB Multilink - USB Port" and the "UMultilink Universal Rev D on USB1 (Name=PEMCC01D5). I have made no changes to the hardware connection and I am still using the 6-pin BDM.

    Can I get any direction to try and figure out why I can no longer connect to the target??


  • Looks like something got cut off in the message.  

    The sentence that was cut was to say that "no changes have been made to the hardware". The Older USB Multilink was simply disconnected and reconnected with the new USB Multilink Universal.

  • Greetings,

    Let us start with the firmware of your new multilink. Make sure it is using the correct firmware. Use the following link and use the firmware config utility to support the HCS08 architecture:

    Takao Yamada

  • Uninstalled then installed firmware from link provided. No change in response.  Still have same error condition and can not connect to target.

  • Greetings,

    That is bizarre. You should also try updating your Codewarrior 10.7 using Help menu -> Check for updates. See if this resolves your issue.

    If not, then you can wait on a patch I am putting together to help resolve user who are using much older CW 10.x Eclipse IDE to be able to use newer PEmicro hardware interfaces.

    Takao Yamada

    • Verified I have the latest version with updates for CodeWarrior 10.7.  Also  pressed "Check for Updates" and it came back saying there were no updates.  Therefore, updating CodeWarrior to the latest version did not provide a solution.

      I would be very interested to see if your patch will make a difference. Current development is shutdown since we can not dial back to the previous version and use the older USB Multilink. I hope you can provide the patch soon. Thank you in advance!!

      • After rereading your last comment, I believe that CodeWarrior is seeing the Microlink interface.  It appears the Microlink interface is not able to communicate or establish a link with the target micro-controller to download the application and thus debug.

        • Greetings,

          If it recognizes the hardware and the firmware config utility is able to update the firmware, then I am more leaning towards a hardware problem and not in drivers or firmware or software.

          Do you have a scope? Try monitoring the BKGD and RESET lines and make sure the signals are clean. No RC like curve, but instead sharp rising edges. Also, if the voltage is not reaching a full 5V (or 3.3V if VDD is that value) then it could also mean there is a current-limiting resistor somewhere on BKGD or RESET that is preventing voltage from reaching the proper high signal.

          Takao Yamada


            On the old USB BDM Multilink the 6-pin BDM connector that was attached to the target board had "RESET" and "TVDD" connected. As such the "RESET" pull-up resistance was providing power to the "TVDD" pin. The "TVDD" power requirements on the "RESET" pull-up resistance did not pull down the voltage enough to cause a reset issue. Why this was done I do not know, but for whatever reason this worked and proper operation was obtained for downloading and debugging.

            With the new USB Multilink Universal it appears the power demand on "TVDD" is greater thus bring down the voltage on the "RESET" pull-up resistor more so that the target was in a sustained reset mode.

            When "RESET" and "TVDD" were separated, as they should be, the USB Multilink Universal provide proper download and debug operation.

            Therefore, I have to chalk this one to "operator wiring error".

            Thank you very much for helping me along with the issue and helping me to move in the direction to resolve our connection issue.

            Case closed!

  • I understand this setup worked with old multilink. It does not mean the new multilink is the exact same board design.

Add comment

   Want to comment? Please login or create a new PEmicro account.

© 2020 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement