Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
search inside all forums
Multilink Universal Rev.D, Connection Issue with CodeWarrior v10.7
danica j. Sep 11, 2019 at 04:33 AM (04:33 hours)
Staff: Johnny N.

  • Hi,

    Recently my team bought some Multilink Universal Rev.D for debugging. Before, Rev.C is used and works fine.

    Now, with the same condition (same project code, same CodeWarrior v10.7, same Computer Win 10 system...) Rev.D encounters an error while connecting to the interface hardware. As I cannot attach a screenshot here, I try to describe in words as detailed as possible. "P&E Connection Assistant" reminds me to retry/re-specify the connection with the following parameters:
    "USB Multilink-USB Port",
    "UMultilink Universal Rev ? on USB1 (Name=PEM415C71) (Autodetected)"
    "BDM_SPEED=(0): Multilink=1.00Mhz, Multilink FX=25.00Mhz, OSJTAG=0.25Mhz"
    I Refreshed and Retried many times, but useless.

    In Computer Device Manager, I can see "pemicrowindrvr" and "USB Multilink 2.0".
    Blue and Yellow LEDs of Multilink are both turned on.

    Could you please help analyze this issue? It seems Rev.D is the only option buyable from your website. It's urgent for us. Look forward to your reply. Thank you very much.

    Best Regards,
    Danica Jiang




    Comments

    • And the driver is the newest one downloaded from pemicro.com/multilink and is successfully installed.

      • Hi Danica,

        Do you still need help with this issue?

        Regards,
        Johnny
        PEmicro Support

        • Hi, Johnny

          Thank you for your continuous follow-up. The issue has been solved by upgrading Multilink firmware.

          I find that when using older version software applications (e.g. CodeWarrior v10.7), we need to first run the "Firmware Updater Utility" to select the target processor architecture MANUALLY.

          However, with latest software applications (e.g. CodeWarrior v11.1), there will be automatic prompt reminding to update firmware the first time Multilink detected.

          Anyway, thanks for your help.


          Best Regards,
          Danica
          NXP

          • Hi Danica,

            Codewarrior 10.7 doesn't have the firmware support for the USB-ML-UNIVERSAL Rev D. When you download our "Patch for Eclipse Codewarrior 10.x Software" and apply it to your installation, support will be added and it will do the firmware update automatically.

            http://www.pemicro.com/faqs/faq_view.cfm?ID=211

            -Johnny
            PEmicro Support

            • Hi, Johnny

              Thanks a lot.


              Best Regards,
              Danica
              NXP

  • Hi Danica,

    What MCU are you trying to debug/program and which port on the Multilink are you using?

    Regards,
    Johnny
    PEMicro

    • Hi, Johnny

      I tried in NXP MWCT1013VLH before. And I use Port A JTAG/ONCE on the multilink.


      Best Regards,
      Danica
      NXP

Add comment


   Want to comment? Please login or create a new PEmicro account.







© 2019 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement