Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
search inside all forums
Multilink not resetting processor
Ian L. Sep 4, 2019 at 10:41 AM (10:41 hours)
Staff: Takao Y.

  • MCU: Freescale: MCP5517
    BDM: Multilink RevD
    Programmer: ICDPPCNEXUS CPROGPPCNEXUS

    Hello,

    I am having a problem post programming. The multilink is still connected (and needs to remain so) but the MCU isn't running. I've read elsewhere on this forum that the RE reset command holds the process in reset and the GO command should restart it. However these commands don't seem to work.

    How can I run the processor without powering off and on again.

    Thanks.




    Comments

  • Greetings,

    What version of PROG and ICD do you have?

    Starting version PROGPPCNEXUS v6.9.00.00 I made a change in RE command so that now it will reset the device and disconnect all debug signals which should allow the device to run on its own as if the multilink is not connected.


    Takao Yamada

  • Greetings, 

    Thanks for the speedy reply. This sounds like what we need. However we are already on version 6.09.00.00 (according to the About screen).

  • Greetings,

    Could you download the latest version of our PROG software with a trial license and after loading the algorithm just simply call the RESET command and see if the behavior is the same. I want to know if this is just a matter of software version or we need to investigate deeper into this issue:
    http://www.pemicro.com/downloads/download_file.cfm?download_id=194


    Takao Yamada

  • Hi Takao,

    That fixes the problem, thank you.

    Please advise how we can get an official release.

    If you would like to email me directly, please use ileonard@martin-baker.co.uk

    Thanks.

  • Greetings,

    To get the latest software you will require an updated license.
    Could you open a support request ticket in Support page -> Support requests? There I can help you further.


    Takao Yamada

  • Greetings,

    Any update on this?


    Takao Yamada

  • Greetings,

    I followed this up using my Martin Baker account and all is now resolved.

    Thank you.

Add comment


   Want to comment? Please login or create a new PEmicro account.







© 2019 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement