Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
search inside all forums
firmware update failed, multilink version D
li c. Aug 13, 2019 at 09:14 PM (21:14 hours)
Staff: Takao Y.

  • Hello:
    Good moring.
    I have a miltilink versionD, when i program the target processor S9S12G64F1VLC, the multilink shows below information:

    'Interface hardware detected with old firmware'
    'updating, please wait'
    'original firmware:88.194'
    'current firmware:1.237'
    'update firmware:6.12'
    'err:check port ,power and connections'
    Then shows:
    'err:check port ,power and connections.firmware update failed,Retry?'


  • Greetings,

    What software are you using?
    Did you try using the multilink resource CD yet and used the firmware config utility?

    Takao Yamada

    • I have installed the software download via your link, but the problem still exists.

      I use the codewarrior 'CW_HC12_v5.1_SPECIAL' and PC OS I used is Win10.
      And the multilink drivers had been installed correctly and recognized correctly by PC.

      Before I programed the target processor, I had used the firmware updater utility to update the firmware to 'RS08/S08/S12(X)(Z)/ColdFire+/ColdFire V1' architecture.
      What's the impact of this updating operation?

      And could you tell me how to deal with this problem?

      • The version of the codewarrior I used is V5.9.0

  • Greetings,

    First resolve the firmware updating. Then we can deal with codewarrior later.

    If you cannot firmware update using the firmware config utility, then that is a major problem. This is supposed to force update the firmware to the latest. What is the version of the utility you are using (check the title bar at the top of the utility), and what firmware file is automatically selected in your case?

    Takao Yamada

    • Good morning,

      The firmware update utility works well, I can use it to update firmware manually.
      But when I program a target processor, a message box shows needing update firmware and then shows firmware updating failed.

      The version of the firmware update utility is V

      And the firmware file automatically selected is 'usbmlfsufbdmens.1017'.

  • Greetings,

    Good, the firmware config utility is working and therefore now we can work on getting Codewarrior to behave.

    Read my FAQ and get the patch for your IDE. Once you do this then you will no longer see the firmware update message:

    Takao Yamada

    • I am having a similar problem. Firmware update utility works fine but I get the error when trying to run the debugger.  I am running the debugger in stand alone mode, directly executing ../pemicro/CW_icdppcnexus

      • Greetings,

        Did you update the software? Did you try the FAQ I posted? It has a solution for PPCNEXUS as well. These patches work for 99% of customers so you better give it a try.

        Takao Yamada

      • Where do I go to update the software?  I am using the version supplied with the xpc56xx evaluation board

        • Greetings,

          So you unzipped the folder, read the readme.txt file, and found the new cw_icdppcnexus software that exists inside this FAQ, and gave it a try already? That was very fast.

          Takao Yamada

          • Thanks Takao,
            This solved the problems I was having

    • Hello, 
      I update the path and folder according to your link. but the problems still exists when I debug the target processor

      • Greetings,

        I hope you followed the instructions found in the readme.txt file. Did you replace the entire folder, or did you merge the new files into the old folder. You are supposed to merge. Double check your work.

        Takao Yamada

        • From the readme file ...

          3. Copy the "pemicro" folder from this archive to the directory. Do not merge files as this may cause intended behavior.

          Which is it? to merge or not to merge?

          • Greetings Ken,

            Different patches have different instructions.

            For your setup for Power you should NOT merge. I am trying to speak with the original poster (li c) about his HC12 setup which require merging the files. Your setup is done and no longer require any more changes. You should be all set. I will try to direct my replies to specific people by calling out their names from now on.

            Takao Yamada

        • Hello,
          The problem still exists.
          I download the patches for (S)12(X) 3rd Party Software. The instructions is as below according to the 'read me file':
          1. Search the application directory for the DLL file (unit_12z.dll).

          2. When the file is located, rename it to unit_12z.dll.backup or archive it so you can restore it at a later time if necessary.

          3. Extract all files from this archive to the directory.

          4. Search your C:\windows\system32 directory for the DLL file. If the DLL is there, also replace it with the latest version.

          5. Restart the application debugger and try to debug your target board.

          6. If the application is still unable to detect the P&E interface, install the latest P&E drivers from

          So I copy all the files from the downloaded folder to the target folder(on my PC is 'C:\NXP\Prog'). But there is no unit_12z.dll file in the path of C:\windows\system32 directory on my PC.

          After these instructions, does it need to update the firmware via firmware update utility? And the automatically elected file of firmware update utility is still the 'usbmlfsufbdmens.1017'.

    • Morning Takao,

      I have exactly same problem as Li. The only difference is that I'm using the Codewarrior v10.2 and the target processor is MCQE32. I have download your patch for 'S08.RS08.CFV1', reinstalled CodeWarrior to C:\NXP folder, but I din't find a folder named P&E under prog. What I have is "C:\NXP\CW MCU v10.2\MCU\prog" and "C:\NXP\CW MCU v10.2\Drivers\P&E". And I tried to merge/replace patch files to both folders but nothing happend, the problem still existed. The driver I have is USB Mulitilink and windriver Please help, thanks.


      • Greetings Xiao,

        The patch will not work on Codewarrior 10.2 because it is not a classic Codewarrior. You require a different solution. Please go to Support page -> Support request to create a separate ticket and I will have someone help you out.

        Takao Yamada

  • Greetings Li,

    C:\NXP\Prog is not the right directory. Within the C:\NXP path is there a Codewarrior in there? Within the Codewarrior folder you should see the Prog folder.

    Takao Yamada

    • Hello:

      In C:\NXP folder, it includes '(Helper Apps)', 'bin', 'DownloadManager' , 'Drivers','Help','lib','Lint','ProcessorExpert','Prog','Release_Notes' and 'Templates' folders but no codewarrior folder.

      And the unit_12z.dll file is located in 'C:\NXP\Prog'. So I copy all the files included in the patches to the 'C:\NXP\Prog'. But there is no unit_12z.dll file in the path of C:\windows\system32 directory on my PC.

  • Greetings,

    This patch only works if you have a Codewarrior properly installed. Please install the software and make sure you have a Codewarrior folder within C:\NXP or C:\program files (x86)\Freescale\. Once you have the software installed, then repeat the patch work again.

    Takao Yamada

    • Good morning:

      This problem has been solved according to your guidance. I didn't change the installation path when I reinstalled the codewarrior.

      This problem has confused me so a long time. Thank you very much.

    • Greetings,

      The problem above had been solved.

      But now I want to debug the MPC5644 MCU with the same multilink. The version of codewarrior is V5.9.

      After I click the debug button, it shows "undected port" on the debug page. Kindly give the solution on this problem.

    • Good morning:
      I reinstalled the multilink drivers, so the problem of "undected port" has been solved.
      but when I click the "connect(Reset)"&"Hotsync"button on the debug page, it shows below information:
      "P&E interface detected--flash version1..1"
      "Debugger retrying force to background mode"
      "Cannot enter background mode".

      The version of codewarrior IDE is 5.9.0
      The type of MCU is SPC5644;
      The multilink is VersionD;

      Kindly give the solutions of this problem.

      • Takao,
        I have a related question. I know that if these devices are censored, the debugger responds as li c. indicated above. my question is: Is there any way to definitively determine that one of these NXP processors is censored? I'd like to be able to prove a device is censored, and not wonder if my connections to it are faulty.

        • Greetings,

          Unfortunately there is no way to discern between a bad communication to device, or the device being censored and not being able to enter debug. We essentially send the command to enter debug and attempt to write/read registers to see if we made contact. If the read attempt comes back nothing then we were not able to confidently contact the device. The device does not reply back with an error. Some devices, if set up this way, may reply back with a reset toggle indicating the device has reset due to wrong password. But it is hard to determine if that was driven by the device or other external means. But that could indicate that at least communication was good but the device is still censored.

          Takao Yamada

          • Thanks Takao,

            Is there some way to monitor the performance of the !RESET line through the multilink? or do I just need to hook up a scope?

            thanks again,

  • Greetings Li C,

    Go back to the link I sent you about the Codewarrior patches. Find the one for Qorivva PowerPC Nexus patch and update your Codewarrior. Then you should be all set.

    If you are using the latest patch, please also try lowering the debug shift frequency and adding 200ms reset delay.

    If you still have issues even with these changes, then you probably either have a censored device or your communication is bad.

    Takao Yamada

    • Hello Takao:
      I tried according to these solutions, the issue still exists. It still show the err message information above. It even indicates that "Error in -resetfile parameter. File not found" after I change the pemicro folder according to the patches instructions.

      And the blue and yellow lamp of the PE multilink are both on.

      And the multilink works well when I debug the S9S12G64 and S9S12G128.

      Kindly give the solutions.

      • Greetings Li,

        The patch should have cw_progppcnexus and cw_icdppcnexus softwares Confirm that your patch has these cw_ software. If not, then you did not install the correct patch and did not follow the correct instructions.

        Let us try a different route. Download this:

        Get the trial license and see if you can connect to your target device. If so, then you have at least someone to work with for Qorivva PowerPC devices. The patch I gave you should be the same thing as this software.

        Takao Yamada

Add comment

   Want to comment? Please login or create a new PEmicro account.

© 2019 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement