Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
search inside all forums
Install MultiLink USB Dongle Driver on Windows 10
Sohail H. Aug 5, 2019 at 11:56 AM (11:56 hours)
Staff: Takao Y.

  • Need the right steps to download and install your MultiLink USB Dongle Driver.
    I tried downloading and installing I get the following in Device Manager:
    Jungo > pemicrowindrvr
    > WindDriver

    Still the device does not respond using CodeWarrior
    or CF Flasher


  • Greetings,

    You must be using classic Codewarrior. Check out my FAQ on this and patch up your software. Your drivers are fine:

    Takao Yamada

  • I gave up on CodeWarrior.
    I am back to CF Flasher to reset the flash.
    Selected my target and BDM communication: PE_USB_ML.
    I have only one USB on the laptop.
    I selected USB Port 1, Speed 1.

    Tried to erase entire flash. It does not work.
    I get the following message: "Could not initialize the BDM Device."

    When I installed the drivers from your website I get the following in my Device Manager
    USB Multilink 2.0

    Jungo is on the top level with Monitors and Network Adapter, not under USB Controllers, or USB Devices, or USB Connector Managers.

    I am not sure the computer is seeing it as a USB connection. It appears the driver is installed like a new device.

  • Greetings,

    Even with CF Flasher you will need to patch up the software with the FAQ I sent you. This is because the software you are trying to use are older than the hardware interface you bought.

    What architecture are you trying to program?


  • Takao


    I did install the patch. It still does not work.
    Saved the previous and updated the new.
    Noticed the new date on file.
    Updated all the files with the same name, in CodeWarrior, PEMicro, and Windows directories.

    I noticed, Jungo, driver is installed as an independent device.
    It seems it is not recognizing it as a USB device.
    I get unable to connect to BDM device error.

    When you configure it prompts you for a USB port.
    I tried all the port numbers I have.
    But it does not see it anywhere.

    Tazukete Kudasai.


  • Greetings,

    Could you detail which multilink you are using? If you are using multilink universal/FX then use the attached installer for drivers and find the firmware config utility. If it can see your multilink then your drivers are fine and your CF Flasher should detect it. If you are not using multilink universal, then do NOT install the following drivers:

    Takao Yamada

  • It says "USB ColdFire Multilink".
    On the backside it has a label:
    USB-ML-CFE Rev. C
    USB BDM Interface
    For ColdFire Devices
    Rev. C 0406

  • The target configuration is as follows:

    BDM Communication

    Attempt to erase entire flash give an error:
    Could not initialize BDM device

    Device manager shows the following:
    USB Multlink 2.0

  • Greetings,

    Install our 64K Trial version of our PROG/PKG CFZ software, open PROGCFZ software, get the trial license by clicking on the link, and then try to connect to your target board using our software:

    See if you can get some kind of communication. If the software prompts you for an algorithm file to load, then you have entered debug mode on this device which is good! If not, then you most likely have some kind of hardware connection problem.

    Takao Yamada

    • Takao 
      It worked out. I am able to configure, reset flash, and program. Thank you very much for continued support and help.
      Taihen ni arigato gozaimashita.

Add comment

   Want to comment? Please login or create a new PEmicro account.

© 2020 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement