Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
search inside all forums
Unable to debug with Multilink Universal a board with MK20DX64 or with MK22FX512
. Feb 22, 2018 at 12:06 PM (12:06 hours)
Staff: Takao Y.

  • Hello to all!

    I have developed an electronic board with the possibility of using one or the two processor in the topic title.

    I have assembled four cards with MK20DX and 2 with MK22FX. Only one of one type and one of the other works.

    I use MCUXpresso and the Multilink Universal as debugger.

    The problem is that many times on blanked chips, the debug phase is not successful. I get a message from p&e assistance that say "an error occured while connecting to the interface hardware or target..." an the another erro message


    "Error in services launch sequence
    PEmicro GDB Launch Failure : The GDB Server was not able to establish a connection to the target processor. Please check your connections and power. Verify that the launch settings in the Debug Configuration are accurate."

    In the cards that do not start I have found these symptoms:
    The reset line is driven low by micro. I have 4.7K pull up on reset and 1uF Capacitor between the reset line and the ground. I also try to remove the capacitor, or the resistance or both without successfull. Also I have a pull up on NMI port to prevent the EZPROG mode. This port still high. Iowever I tried to put also a 10uF capacitor between NMI port and ground to try to see if there were problems with the timing of the micro power up and the situaxione has changed.
    The reset line with this situation go high, when I start the debug session I receive this message "device is secure. Erase to unsecure?" If I type yes, I return back to the previous situation: reset driven low and I received again the error messages.

    I do not think there are problems on the board because after replacing one MCU with the issue with another, in the same board, I could program the MCU.

    Also I do not think there are problems on the configuration of the debugger since in some cases it works.

    Any suggestion? Thanks!




    Comments

  • Greetings,

    Based on your findings and the errors for GDB Launch Failure and error connecting to target seems like you may simply need to make a few configuration changes to get this working. Go into debug configurations and try lowering the debug shift frequency and adding 200ms reset delay. This will improve the communication between your PEmicro hardware interface and your target board.

    All the other hardware connections like the pull up and capacitors are fine. I do not think you need to make any major changes considering it works on some chips and not others.


    Takao Yamada

  • Dear mr Yamada 
    thank you for your reply

    I've already tried this solution of changing the debug shift frequency and the delay times to reset, but also this solution didn't work.

    Also I tried to pull up the SWD_DIO line and to pull down the SWD_CLK line, but I didn't get changes.

    I have already read many posts of similar problems and tried various solutions, but I have not yet found a correct way to resolve.

  • Greetings,

    Are you using JTAG, or SWD? Make sure to modify the debug configurations based on which protocol you want to use.

    You may need an oscilloscope and start comparing and contrasting a working condition and non-working condition.

    Are you sure the non-working chips are in good condition? You indicated if you replace the chip with another, then the set up works. Have you gotten this non-working silicon to work at all? Do you have more silicon to work with?


    Takao Yamada

  • Greetings

    I'm using SWD, I think that the debug configuration is correct since it with works with some MCU.

    With oscilloscope I can see changes in the reset pin, as I said in the first post: In working condition is high and I can see the debugger drive it high and low. In no working condition I can have two situation : usually reset line low and then i get error message with no variation. The reset line still low. Also I can have a situation where reset line is high and when I start the debug session I receive this message "device is secure. Erase to unsecure?". If I type yes the reset line go low and then I get the usual error message

    I don't know how to check if the chips are in good condition. Anyway they are all new and bought recently.

    thank you

  • Greetings,

    Even if you disconnect the P&E interface, the RESET is low from the beginning? You should check your schematic to find out what could be pulling it low. Only when the RESET is high should you attempt to connect the P&E interface and start a debug/program session.


    Takao Yamada

  • Greetings

    Yes, the RESET is low from the beginning, with P&E interface disconnect.

    I check the schematics and if I disconnect the reset pin from PCB, I have high level on PCB and low level on the lifted up reset pin.

    So it seems that it's the mcu that brings the reset level down

  • Greetings,

    Sounds like a bad silicon. Chuck it and move forward.


    Takao Yamada

  • Greetings,

    Any update on this? Were you able to confirm that it was a bad chip?


    Takao Yamada

  • Hi...as per my knowledge changing configuration can help you here.Go into debug configurations and try lowering the debug shift frequency and adding 200ms reset delay. This will improve the communication between your PEmicro hardware interface and your target board.

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement