Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service


Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept



search inside this forum
search inside all forums
Cyclone FX with Microchip ATSAMC20
Manuel T. Feb 7, 2018 at 10:13 AM (10:13 hours)
Staff: Juan S.

  • Hello,
    I'm trying to set the "security bit" to Microchip ATSAMC20. I cannot find the relative programming sequence inside Cyclone Image creation utility (v.6.68.00.00) so I tried to secure device inside code. After correctly programming MCU, I tried to perform a subsequent MASS ERASE without success.
    The Cyclone FX display shows error $00000007 any time I try to erase or program a secured device. I tried also a Cyclone for ARM programmer with the same behaviour.
    What am I doing wrong? What is the correct operation to erase a secured device?

    Thank you in advance.
    Best regards.




    Comments

  • Greetings,

    The unsecure feature has been added to our latest firmware of the cyclone. Please download the latest software and firmware here:
    http://www.pemicro.com/downloads/download_file.cfm?download_id=481


    Takao Yamada

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement