Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service


Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept



search inside this forum
search inside all forums
Update firmware fail with multilink universal FX Rev B
Eric F. Jan 4, 2018 at 10:15 AM (10:15 hours)
Staff: Takao Y.

  • Hello, 

    I have a multilink universal FX (rev B) but it does not work. On my point of view, there is a problem during the update of the firmware. The interface failed.
    I have installed the correct version of drivers, by downloading them on the site (http://www.pemicro.com/faqs/faq_view.cfm?id=229&Product_ID=15320350), but nothing changed.
    For your information, I use COLDFIRE MCF52259 microcontroller.

    Currently, I using another multilink universal FX that works perfectly, but it is a Rev A I borrowed to my colleagues ; but I’d like to work with mine.

    Can you help me please ?

    Thank you,

    Best regards,




    Comments

  • Greetings,

    Are you using the latest firmware updater utility?
    http://www.pemicro.com/downloads/download_file.cfm?download_id=346

    If you use the older utility, it does not understand the newer rev B models.


    Takao Yamada

    • Hello,

      I downloading the latest firmware, but when I select "run" on CodeWarrior, nothing change, it is the same problem.
      After that, I decide to install manually the new firmware with PEFirmwareUpdater.exe and the result of update is succesfull but when I retry on Codewarrior, I've the same error.
      Firmware version : usbmlfxufbdmens.0973

      I've take screenshot of the window if you don't seen what I explain.

      Have you another idea for that problem ?

      Thank you,

  • Greetings,

    What do you mean you select Run? Were you able to get past the firmware update issue? Or are you resolved on the updating and now concerned about your debugging?



    Takao Yamada

  • Hello,

    The firmware is correctly update when I pass by executable PEFirmwareUpdater.exe

    But when I want to flash a new project on my microcontroler with Codewarrior, the program start to debug but he crash because the firmware doest not arrive to update.

    you can see my screenshots on the Support Request ID # 25813

    I don't understand.. everything looks good

    Thank you,

  • Greetings,

    Which Codewarrior are you using? You may need to update it to the latest version. If using Codewarrior 10.x, then go to the Help Menu and check for updates. If using classic Codewarrior, use the following FAQ to learn what you must do:
    http://www.pemicro.com/faqs/faq_view.cfm?id=211&menu_id=faqs


    Takao Yamada

  • Hello,

    Indeed I was use Codewarrior 10.6. I have update to the last version and everything work perfectely.

    Thank you for your help

    Bests regards,

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement