Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept

search inside this forum
search inside all forums
Activation Page not showing
Freddy C. Dec 26, 2017 at 11:16 AM (11:16 hours)
Staff: Takao Y.

  • I have a PE Micro Multilink Universal bought from Pentair. I installed the software but it does not show  the activation page. I have tried in 3 different PC's with no success. 

    I s not the first time I do the same procedure. This Time I Wanted to do it downloading the software from the page. After this I need to download Pentair Firmware update in order to get my boards updated. Once connected the kit and the proper filed is being selected, the activation page is suppossed to appear to complete the process. What it does is tha shows a Black screen for a second and then closes with no option to respond.

    Please I need Help

    Freddy Cornieles


  • Greetings,

    1) What software are you trying to use?

    2) Could you also detail the following:
    a) Which operating system are you using?
    b) Which revision of the multilink universal are you using?
    c) Did you make sure to update the multilink universal as mentioned in the quick start guide? You must do this before using the multilink universal:

    Takao Yamada

  • Pentair automation firmware update which runs on PROG12Z

    IntelliTouch®, EasyTouch®, SunTouch® and i-Link Firmware Updates

    Windows 7 Proffesional

    Rev D

    Yes I did update multilink

  • Greetings,

    Do you actually have PKG12Z with PROG12Z installed on your computer?

    C:\pemicro\pkg12Z, or

    and look for PROG12Z and CPROG12Z. If these files do not exist, that means you have not purchased a license for this product from P&E. This is required before you can run the .bat files. The black screens you are seeing are the .bat files opening up a CMD prompt and trying to automatically run the PROG12Z on your computer. But since it cannot find it, it immediately shuts down.

    Takao Yamada

  • This is what is on my PC


  • Greetings,

    If you do not have PROG12Z.exe or CPROG12Z.exe, then you do not have sufficient software to use the items found in C:\pemicro\pkg12z\bat.

    In the past you must have worked on machines where the executables I have detailed were already installed. However on these new computers they do not have the software.

    You should contact Pentair about getting the proper software and license so that you can move forward. Since you did not purchase any of the software or hardware from P&E, there is not much I can do to help.

    Takao Yamada

  • I am a Automation Specialist from Pentair. 

    When you say there is not enough software to use, what do you mean? The 3 PC's i Have tried have enough memory t run this kind of software.

    Actually I Have 2 kits with me but the pc's dont have the Cd slot that's why I need to download the software from PE micro web page

  • Greetings,

    I am not talking about memory on your computer. Just downloading the software from Pentair's website is not enough. You must have PROG12Z installed on your machine as well.

    PROG12Z is not a free software and we do not distribute this publicly.
    Please go to Support page -> Support requests and create a ticket for me so we can discuss information like license and software downloads.

    Takao Yamada

  • No I know is not free but in order for this software to sale i need to teach our customers how to proceed...

    I will create that tkt....thanks

Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement