Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service


Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept



search inside this forum
search inside all forums
Issue installing P&E Hardware Interface Drivers version 12.7
Jeff C. Dec 5, 2017 at 02:32 PM (14:32 hours)
Staff: Johnny N.

  • Hello,
    I'm having trouble installing hardware drivers version 12.7. After downloading from the website, I install them but get a message saying drivers were not properly installed (I'm using Windows 7 64 bit). In device manager it just shows an unknown device, it does not recognize it as WinDriver. Here is the windrvr6_install.log file:

    WDREG utility v11.7.0. Build Oct 26 2014 09:21:13
    Log from Tue Dec 05 09:54:36 2017

    Command line: C:\PEMicro\PEDrivers\supportfiles\Drivers_12_7_0\windriver\wdreg_gui.exe -inf C:\PEMicro\PEDrivers\supportfiles\Drivers_12_7_0\windriver\windrvr6.inf -log C:\PEMicro\PEDrivers\supportfiles\Drivers_12_7_0\windriver\windrvr6_install.log install

    Processing HWID *WINDRVR6
    Trying to create virtual device
    Installing a signed driver package for *WINDRVR6
    LOG ok: 1, ENTER: DriverPackageInstallA
    LOG ok: 1, ENTER: DriverPackageInstallW
    LOG ok: 1, RETURN: DriverPackageInstallW (0xA)
    LOG ok: 1, RETURN: DriverPackageInstallA (0xA)
    difx_install_preinstall_inf: err a, last event 0, last error 0. ERROR_BAD_ENVIRONMENT
    install: completed successfully
    STATUS_SUCCESS

    After plugging in the Multilink Universal it installs the driver for it but I get this message:

    "Windows cannot verify the digital signature for the drivers required for this device. A recent hardware or software change might have installed a file that is signed incorrectly or damaged, or that might be malicious software from an unknown source. (Code 52)"

    I have another laptop that is using the drivers that were installed with Freescale KDS, version 12.3 and everything works perfect.




    Comments

  • Jeff,

    I am wondering if something is corrupted or not properly installed on your PC. What you can try is uninstalling Jungo-> Windriver and Jungo -> USB Multilink 2.0 from Device Manager and checking the option to delete their files from your system. Then redownload our drivers and install them again under a local administrator account or a domain adminstrator account (if this PC is on a company domain). Drivers can be downloaded here
    http://www.pemicro.com/downloads/download_file.cfm?download_id=53

    If this doesn't work, you should try temporarily disabling the Window 7's driver signature enforcement. This is done through the Advanced Boot Options when Windows is booting up. There are multiple guides online that show you how to access this option.

    Regards,
    Johnny
    PEMicro

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement