Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
search inside all forums
Eclipse Oxygen.1 & Debug Plugin 3.2.4 Says Devies is Flash Protected
. Oct 31, 2017 at 12:17 PM (12:17 hours)
Staff: Zahar R.

  • I'm using Eclipse Oxygen.1 on Win 7 x64 with the latest CDT (9.3.3) and the GNU ARM PEMicro Interface Debugging Support plugin (3.2.4) which was an update published 10/24/2017. MCU is MK22FX512A. When I go to program my device it indicates that the device is secure, even though it isn't. This prevents me from flashing my debugging code, although I can erase the micro. 

    This setup worked before the 3.2.4 update (3.2.1 I believe) and I've verified the micro can be programmed using a different machine with a different version. I've tried rolling the plugin back to 3.2.1 but it seems the older plugin versions are removed with each new release.

    Anyone else run into this issue?




    Comments

  • I should specify that this is with a USB Multilink Universal Rev B

  • Hello, 

    Can you please email your .s19 project file to zahar "dot" raskin "at" pemicro "dot" com?

    To downgrade to an earlier plugin version, you have to first uninstall current P&E plugin, and then install the previous version.

    I will try to track down the exact device that you are using to do a validation of this use case in our lab.

    Best Regards,
    Zahar
    P&E

    • So I'm not sure if closing out of Eclipse and verifying all of the associated debug executables (PEMicro GDB server and GDB client) freed something up, but the same Eclipse/PEMicro plugin that was giving me issues the other day is now working. If I run into this issue again and find a way that it can be replicated, I'll make sure to revisit this thread and send you an .s19 to test.

      Thanks for the quick response!

  • Hi, glad that you got your setup up and running!

    Best Regards,
    Zahar
    P&E

  • Turns out that the debug configuration was still using the programming file for the NXP K22FN512 on the Freedom board. I had switched over to my custom board with an NXP K22FX512A, which is just different enough that it would would sometimes program and not other times, as the images I am debugging are going in the higher end of the internal flash regions. The K22FX512A actually has 640K of internal flash under certain configurations, whereas the K22FN512 only has 512K

  • Hi, that makes sense. When you are changing the target device in your development setup, our recommendation is that you choose a matching target device under debug configuration. 

    Best Regards,
    Zahar
    P&E

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement