Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept

search inside this forum
search inside all forums
NXP FRDM-KL02Z Comm Issue
Richard G. Oct 29, 2017 at 08:41 PM (20:41 hours)
Staff: Zahar R.

  • I have two Freescale/NXP KL02Z eval boards that I'm just trying to connect to for the first time via the Kinetis Design Studio 3 IDE. At one time both boards came up as OpenSDA devices but the 'Port' selection box in the Debugger Configuration window was blank. Assuming it was a 'dated software' issue I've tried to update the software and and embedded code and managed to finally get it so that neither board comes up once plugged in. The symptoms now are this:

    1) When plugged into the USB port, either board does not even show up as a USB device in the device manager window.
    2) When I hold the reset button down and plug in, they show up as a USB Mass Storage Device and additionally under the Portable Devices section as a BOOTLOADER device. That seems reasonable.
    3) After downloading the file I've dropped the BOOTUPDATEAPP_Pemicro_V111.SDA file into the root directory of the 'BOOTLOADER' directory (the connected board) and power cycled the board with no apparent affect. (this was per the BOOTUPDATEAPP_release_notes.txt included in the zip file).
    4) I've done the same with the MSD-DEBUG-FRDM-KL02Z_Pemicro_v118.SDA, DEBUG-APP_Pemicro_v108.SDA, and DEBUG-OPENSDA-E200_Pemicro_v110.SDA with the same effects.
    5) When I double-click on the SDA_INFO.HTM I get the following information:
    Board Name is: FRDM-KL02Z
    MicroBoot Kernel Version is: 1.05
    Bootloader Version is: 1.09
    Application Version is: 0.00
    DUID is: 74823937-473181AC-3771C80D-B678E678
    EUID is: 6AE3D036-A84B8722-1872AA1A-948168D6
    TUID is: 74823938-473281E9-3784F80B-B83BE678
    TOA is: 86B6E505-EAC2CB27-C2EA9734-E9988D3A
    TOA2 is: 86B6E505-51E7B39D-2E141CE7-76F2F942
    SUID is: 86B6E505-49458799-37239804-8003EC65

    Am I downloading the wrong SDA? Any suggestions?

    Thanks so much in advance.



  • Hi Richard, 

    What operating system are you working under? According to the contents of the SDA_INFO.htm the Bootloader that you are using is outdated. Hence, you will need to use Windows XP or Windows 7 PC to perform your Bootloader update.

    Below is a link to the blog post that describes a details step by step procedure on updating Bootloader and OpenSDA firmware application to the latest version.

    Once the actual Bootloader is updated to the latest version 1.11, the board needs to be restarted in Bootloader mode and then you have to drag and drop the latest MSD-DEBUG-FRDM-KL02Z_Pemicro_v118.SDA into it, and power cycle it again.

    Best Regards,

  • I'm using Windows 10 but have a Win 7 machine and followed the instructions. Worked perfectly. Thank you so very much!!

  • Hi Rich, 

    I am glad you got your setup up and running. The Windows 8/10 changed a few things around, where the mass storage device is being accessed by the operating system on a start-up, which eventually prevents it from properly enumerating unless the Bootloader is updated to version 1.11 or later.

    Best Regards,

Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement