Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept

search inside this forum
search inside all forums
Cyclone Pro to Cyclone Universal
Laszlo Z. Oct 23, 2017 at 03:28 PM (15:28 hours)
Staff: Takao Y.

  • Hi Team,

    I am using Freescale MC68HC908 and MC9S08 controllers in many products.

    Programming is done by Cyclone Pro. The target is connected through a 4-pin(9S08) or a 6-pin(908) cable to the corresponding Cyclone points.

    As I was forced to buy the new Cyclone Universal, I have to face two issues I need your help with. Development is in Canada, production is all over (Canada, China and Tunisia). Now I have a Cyclone Universal, they have Cyclone Pro's.

    #1: Is there a way to generate Cyclone Pro-compatible SAP files using my Cyclone Universal setup? Maybe converting new SAP files to older style?

    #2: This is tricky. There is no problem with the BDM connections for the 9S08, but it seems impossible to use the MON08 (for the 908). The problem is, the RESET pin is simply pulled up, no connection to the programmer, as the Cyclone Pro didn't need it. The new Cyclone Universal works with older boards using the 16-pin (MON08) connection, but not with the ones missing it. It looks like the Cyclone Universal can not rely only on power-on reset, it needs the RESET pin.

    More mystery: connecting the RESET pin on the 6-pin boards does not solve the problem. I'll investigate.

    ERROR CODEs: 0001, 7003, 7009.

    Is there a difference in functionality between these Cyclones?

    Presently I can use both Cyclones with the same cable/target board; the old one works, the new one doesn't.

    Please help me solve this.


  • Greetings,

    The SAP images you create for cyclone universal will work on the cyclone pro.
    Old SAP images you used to have for cyclone pro can be converted to work for both cyclone universal and cyclone pro. The sap_convert utility can be found in your cyclone universal software package. Instructions to use it found in the cyclone user manual.

    Functionally, the transition from pro to universal is supposed to be the same. We combined the pro and max into one hardware with nice features like a touch screen. We made no change to the MON08 interface. If you continue to have issues, we may want to ask for schematics or even a board be sent to us for evaluation. If we get to that point, please go to our support page -> support requests and create a ticket so that our cyclone design engineers can take a look at this situation.

    Takao Yamada

    • More greetings to You,

      Thanks for the good SAP-news.

      Takao, are you saying there is absolutely no reason for one not working, while the other one does? Even with the RESET pin not connected? Is it possible that I got a faulty hardware?

      I'll create a new-style SAP file and use it on both Cyclones, as that's the only difference now.

      I'll report back; it may be useful for others.



  • Greetings,

    From our testing we believe there should be no difference between the 2 cyclones on the MON08 connection. However, we do not claim that there are no problems at all; we may have not caught it in our testing.

    I would like to see where the Cyclone universal fails to program while the cyclone pro works using the exact same SAP image. This can help us debug the issue.

    Takao Yamada

  • Hi Takao,

    My story gets more bizarre by the minute...

    I did not use the same SAP file for the Cyclones. I used their respective Image Creation Utilities on the same .s19 file and stored the image directly to the Cyclone(s).

    I am playing with 3 different circuits; #1 using full MON08 and the others connect only to the needed pins (OSC, COM, Vp) of the MC68HC908KX2. All the other pins are connected to an appropriate level to enter monitor mode.

    The Cyclone Pro works with all 3 of them, the Cyclone Universal only works with #1.

    I started to cut off pins from #1 connector and ended up with only the same pins connected on all 3 boards. Both Cyclones are still happy. HHOOWW??

    The non-connected MODE pins are pulled to the correct levels, as I said, since the Cyclone Pro can program them.

    Another observation:

    Since you told me the new SAP file is compatible with both programmers, I saved the SAP file Using the Cyclone Universal's Image Creation Utility and used the same file in both Cyclones.

    After adding the SAP file to the old Cyclone Pro, it ended up showing error 0012, while the "Images currently on the Cyclone" window did not add the new program. The Cyclone behaved as if it actually had the program, but couldn't use it (error 0060).
    Same with using both the old and new ManageImages.exe.

    This does "something" to the target, as it can no longer be programmed with anything containing Program Trim. (error 7003)
    A program containing only Erase Module restored it. (but only when Program Trim wasn't included)

    So... what do you think?
    It feels like the new SAP file ruins everything, but it bothers me that it still programs board #1.

    I understand that #1 could be different from the rest, but if the Cyclones are identical, they should behave accordingly.

    I am puzzled (and running out of time)


  • Hi Laszlo,

    Although Cyclone Universal and Cyclone Pro have slight hardware interface differences, they should behave the same for MON08 targets.

    There are a few things you may want to pay attention to:

    1. Cyclone Pro can use SAP files created by Cyclone Universal software (in fact, you should always use the latest released Cyclone Universal software for all Cyclone needs), but its firmware must be updated to support the latest features to make it compatible with the SAP image. So please go to our website and download the latest Cyclone installer.

    2. 908KX2 has trim and there's something special about the chip. You must have an external pull up on the RESET line, and you don't have to connect it to the MON08 header. You must have the IRQ line connected to the MON08 header, which provides the Vtst to enter monitor mode once the part is programmed (Reset vector not blank). You should have Pin 13 of the MON08 header connected to your KX2 OSC1 pin for the trim to work if you don't have an oscillator on your board.

    3. For any MON08 devices, the following is a minimum connection setup if the user pulls up or down mode setting pins, and have on board clock (oscillator or high frequency crystal aka not 32KHz):

    RESET or IRQ (for Vtst), Communication line, Power, Ground.

    4. Power on reset works fine on Cyclone Universal. Would you please make sure you have the correct jumper settings on the Cyclone Universal and PRO? Sometimes some target may work with only leak current through the Reset or IRQ signal without proper jumper settings using Cyclone to provide power. Just because it works on some situations does not mean it is properly done.

    5. Error code 7003 and 7009 are trim related errors. Please check your S19 file to make sure they don't contain data in the trim location.

    Best Regards

    • Hi Huajun,

      In your message (that I am answering now) your #1 point became interesting.
      I changed my computer and I am no longer able to put any SAP file, old or new, into my old Cyclone Pro. You said there is a way to update the firmware by downloading the "latest Cyclone installer". I went onto your site and found "Cyclone Pro Single File Installation" under Firmware Update.

      "This package installs all the of the software for the Cyclone Pro. It includes the PEmicro Cyclone USB Drivers, Image Creation Utility, Image Manager, and all supported flash programming algorithms. This is the same software as what you get on the CD.

      Please uninstall the previous version before installing the latest version."

      It says nothing about updating the firmware in the Cyclone Pro, not to mention how to uninstall the original one that came with it.

      The real problem is that we have many Cyclone Pro's spread internationally at our manufacturers, where "someone" has to update them. Please hold my hands and show me step by step what to do, so I could broadcast it to the others.
      Also, I hope your website is available for this download from China and Tunisia, where most of these Cyclone Pro's are.



      • Greetings,

        You can uninstall the previous cyclone pro version using the uninstaller that is found in the cyclone directory, or use Windows Add/Remove.

        To update the firmware, simply install the new software and connect to the cyclone using any of the utilities available. It will automatically firmware update for you.

        Takao Yamada

  • Hi Huajun,

    Thank you for your 5 points. Every one of them were addressed before, yet no solution found.

    The s19 is not in development, it is used in mass production with no issues.
    The Cyclone Pro has no problem programming any of these boards.
    The RESET pin is pulled up with a resistor (regardless of which Cyclone is plugged in, of course).
    I only connect MON08 # 2, 6, 8, 13, 15; the rest (MOD0, MOD1, SSEL) are pulled to their desired level.
    The TRIM error appears only after using the Cyclone Universal (filled from the same good old s19 file). The error can only be cleared by erasing (+programming) the target WITHOUT using Program Trim, as it can not be read at that time.

    All 3 jumpers are present at #1,2,3 to connect internal power to target.

    The connecting header contains 1.2k pullups on the osc and comm lines, as the Cyclone Pro couldn't always compete with some loads connected to these pins on some boards.

    My educated guess is that the two Cyclones are not identical hardware wise; maybe they don't tolerate the Vdd loads to the same degree.

    The only difference I saw between them is the waveform on the comm line: when the Cyclone Universal talks to the target, the high level on one of them is lower, than on the other one. i.e., the target produces 3.7V, the Cyclone 4.7V, or the other way around. It may tell you something. Maybe the new Cyclone can not supply enough current for the whole circuit...

    If you come up with any other suggestion, please don't hold it back.

    Meanwhile I'll try to disconnect some loads to find the problem, or supply the target from another source.


    • Hi Takao/Huajun,

      I got an idea this Morning and it seems to be correct.
      The Cyclone Universal has no problem driving the pins of any of my boards. The problem is not there.
      The problem is that it can not measure the target's frequency, at least not reliably, so any time "Program Trim" is included, it's in trouble.

      Works fine with the MC9S08(SH8).

      Could you please look into the Cyclone Universal's firmware; there may be a bug in measuring the trim of these (almost?) obsolete parts (MC68HC908(KX2/KX8).

      Meantime I'd appreciate if you could direct me to a source to get some Cyclone Pros to help me out. Maybe your exchange program yields some not-so-beaten-up units?



  • Hi Laszlo,

    Thank you for your detailed explanation of the experiments/setup. The 1.2K pull up on OSC1 is something I never heard of, and I wonder if that is causing Cyclone Universal the trouble. The clock circuitry of Pro and Universal are identical though.

    The voltage of 4.7V might be misleading. If we use Cyclone Universal to generate target power at 5V, the output to the target will be 5V. However, due to a voltage follower we used for internal sensing, target interface buffers will be powered at 4.7V. This typically shouldn't cause any issues.

    The voltage of 3.7V from your target and 4.7V from Cyclone Universal confuse me. You mentioned you are using three jumpers which means you are using Cyclone Pro/Universal to provide power to the target through the MON08 header pin 15. Something is not right here. If your target board requires 5V to power up yet your KX2 runs at 3.7V, then you shouldn't use three jumpers since the MON08 header Pin 15 should be your target MCU voltage level. You should use the Power In/Out jacks to provide power to your target board, or use two jumpers together with Power Out jack to provide the 5V to your board which further regulates down to 3.7V to your MCU.

    Would you please check the power settings and remove the 1.2K pull up on the OSC1 line and try again?


    • Hi Huajun,

      You answered my Comment #6. Please read my Comment #6.1.

      I also have a USB-ML-MON08. That can also program all boards and measure/program Trim.

      The weak pull-up is helping to overcome the possible pull-downs on certain circuits; it has nothing to do with measuring the trim.

      By now I did everything in my power to make absolutely identical connections on all 3 boards in front of me. Traces cut, connections severed, etc.

      The one target the Cyclone Universal can measure/program the trim of, has 0x75 for trim, the others are 0xAA and 0xA6. That's the only difference by now.

      I'll try a few more chips in a socket to see if this is a stable trend.

      Can you please look into the firmware (and my latest, #6.1 comments)?



  • Hi Laszlo,

    The trim value obtained by Cyclone Universal or Cyclone Pro or USB-ML-MON08 should be very close. 0x75 and 0xAA or 0xA6 are too far apart, and I suspect that it is not correct.

    The trim measurement was done inside your target MCU, and the firmware source code for both Pro and Universal are the same. I'm confident that it is not a firmware issue.

    At this point I tend to believe that there is something wrong with the Cyclone Universal unit instead of a generic issue.

    Would you be able to send me a target and the Cyclone Universal so I can step through and figure out the problem?

    We don't have any Cyclone Pro in stock, and I'd like to solve the issue rather than dodge it.


    • Hi Huajun,

      I didn't say these 3 trim values came from 3 programmers. I used the USB-MULTILINK to measure the trim values on my 3 boards.

      But you gave me an idea: I measured 10 MC68HC908KX8 trims by all 3 devices I have (Cyclone Pro, Cyclone Universal and USB Multilink), using a ZIP socket and NO OTHER PARTS.
      The Cyclone Universal, the one I have problem with, can only trim half of them, the other half returned 7003 error.
      The Cyclone Pro measured all and came up with the same results as the Cyclone Universal (whichever wasn't 7003).
      The USB-Multilink worked fine, but returned higher numbers (+8...11), than the others.

      All tests were repeated with the same results.

      I hope it directs your attention to the Cyclone Universal's inner workings, as there is nothing else to blame for.

      Is it possible that the one unit I have is defective?


  • Hi Laszlo,

    Thank you for the experiments.It is curious that USB-ML-MON08 returns different trim values (even though it is not a production graded tool). It does use a different clock source. We haven't touch its firmware for many years.

    At this point I do tend to suspect that the Cyclone Universal unit is defective. If you can send it to me together with a couple of the silicon giving it trouble, that will be great! I will look into the issue and if it is the Cyclone Universal's issue, I will replace it.

    Best Regards

    • Hi Huajun,

      Please answer; I need to know the next step.

      Do you need the MC68HC908KX8s my Cyclone Universal failed to program? I can not send you the programmer, as I am using it for development work.



      • Greetings,

        I have create an RMA ticket for you. You should have received an email of how to send your board to us. Please make sure to provide instructions on how to power up the board if it needs external power, and send pictures of how you had it setup on your end. That way it will be easier to replicate the issue on our end.

        Takao Yamada

        • Greetings to you too,

          As you see from the long chain above, I made a little test with a handful of MC68HC908KX8s. No board involved, just a socket. The Cyclone Universal gave me 7003 error message for around half of them (only when I included "Trim"). The Cyclone Pro was 100% successful.
          They both could repeat the results exactly (same trim values measured, always the same chips failed).

          I am using the Cyclone Universal for another controller (through BDM); works perfectly.

          I offered to send you the Freescale controllers that I had problems with, so you could try it using your Cyclone Universal. I kinda' believe you'll have the same results, as it looks like a software (firmware) bug.

          The RMA you sent me is for the Cyclone Universal. I can not live without it for a day. I have only one.

          Can you help me in any other way?


          • Greetings,

            It does not matter the item listed on the RMA. Just send what you think will help us replicate the issue, even if it is a socket board.

            Takao Yamada

            • Hi,

              Thank you for the attitude :)

              I can send you the MON8 - to - 16SOIC ZIP cable with a few MC68HC908KX8s; some programmable, some not. Only the TRIM freq. measurement ends with error; the rest are OK. 908_kx8_trim.08P is the selected algorithm. Erase Module works, Program Trim doesn't.

              Would this be useful?


              • Greetings,

                Yes if it replicates your issue with the cyclone, then it will be helpful to send.

                Takao Yamada

                • Greetings,

                  I just talked Digi-Key into selling me another one with the RMA# attached.
                  I will try that other one; it'll help determining if it's only the old one.
                  Mean time I'll send you both the faulty Cyclone Universal, my programming cable and a handful of chips (good and "bad") for you to see.
                  I'll have 30 days only, so please be within...

                  Thanks for the help


                • Hi Takao,

                  I just bought another Cyclone Universal.
                  This one behaves exactly the same as the previous one; can not measure the TRIM of the same individual MC68HC908KX8s. The Cyclone Pro has no problem.

                  My course of action will be to send my programming socket with some "good" and some "BAD" chips to you.

                  This is the "program" I try:

                  CM C:\pemicro\cyclone_universal\supportFiles_HC08\908_KX8_TRIM.08p
                  EN Erase if not Blank
                  PT Program Trim

                  External Clock
                  Cyclone Clock
                  4.9152 MHz
                  3.0V, 50ms ON, 50ms OFF

                  It works just fine WITHOUT the PT; with the PT it stops with a 7003 error.

                  I convinced Digi-Key to take back one of them, since there is no reason to send it to you.

                  Please do your best to rectify this problem and please keep me updated.



  • Hi Huajun,

    It'll be difficult for me to send my Cyclone Universal to you. I just bought it to work with MC9S08 controllers and it works fine. The Cyclone Pro was borrowed from production, and the MULTILINK does not support the 9S08.

    I am sure you have a spare Cyclone Universal and even a handful of MC68HC908KX8s.
    Can you recreate my few-minute experiment using your parts?
    If you find something with the Cyclone, "you're welcome".
    If not, I'd send you the few chips my Cyclone had problem with, just to try yours on them. If and only if all OK, then I'll need another Cyclone one way or another. Otherwise it's just correcting a software I can download.

    Hope you agree.


  • Hi Huajun,

    Did you try to program the trim of several MC68HC908KX8s?

    I'd really like to know if you found the same error.

    BR: Laszlo

  • Greetings,

    Did you send us your boards and chips? I believe we have not received your items.

    Takao Yamada

    • Hi Takao,

      I moved into a new computer (windows10, don't ask...) and lost some emails.

      It's embarrassing; please create another RMA# for the socket and controllers.

      I'll send them asap.

      Thank you


  • Greetings,

    I simply resent the email of the original RMA ticket. Please check your inbox to see if you got it.

    Takao Yamada

Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2019 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement