Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
PROGPCCNEXUS cannot enter Background mode
Raphael M. Sep 13, 2017 at 10:46 PM (22:46 hours)
Staff: Takao Y.

  • Hi,

    I want to flash a MCP5567 with the PROGPPCNEXUS-Flash Programmer. But i always get the message "cannot enter background mode, Check connections".

    The drivers are installed. Also i turned down the frequency and added a delay. I checked the connections and the TDO,TDI,... seems working. When i want to connect they are going high several times. I tried an other PCB with the same microcontroller. I updated the firmware of the universal multilink we want to use.

    For us it seems to be a configuration problem or probably a problem with the drivers. But i have the newest 12.4.

    I am pleased about new ideas!

    Regards

    Raphael Mencher




    Comments

  • Greetings,

    1) Has this worked in the past, or is this your first attempt?
    2) Are you using any custom ribbon cables, adapters, or other unique setup?
    3) Are you connecting all 14-pins of JTAG pins? If not, which pins are you omitting?
    4) Which P&E hardware interface are you using? Did you make sure to use the latest firmwares?


    Takao Yamada

    • Hey,

      1. In the past it worked but not for me (for me it's my first attempt). So i assumed this project from someone else. But with him i am in contact and he don't have any idea.

      2. No i am using just the original ones.

      3. Yes i connect all of them. So just using the ribbon cable connected to the port A and an adapter to connect to the microcontroller.

      4. I am using the USB Multilink Universal REV.C and i updated the firmware two days ago. Now it is 9.81.

      Raphael Mencher

  • Greetings,

    1) Are you using the exact same hardware set up as your colleague? Have you tried other hardware interfaces that may be available?

    New questions:

    5) What software version are you using?

    6) Have you checked with your colleague whether your device might have censorship within the shadow block? If so, it may be password protected. If you know the password you need to go into "advanced" options within PROG and insert the password.


    Takao Yamada

    • Greetings,

      1) yes I do. I don't have another one. But I checked the pins of the multilink and it seems working regarding to the trouble shooting in the datasheet.

      5) 6.22 of progpccnexus

      6) I asked them but he said there is no password. If so is there a way to delete it?

      7) one thing I remarked. When I install the driver for the version 12.4 it changed the name of the driver. It's not windriver it's something like pemicrowindrvr. Could this be a problem?

      Raphael Mencher

  • Greetings,

    6) If your colleague did not use a password, then no need to worry about it. I would not dabble in it unless you must.

    7) The driver is not a problem. If the software can detect the hardware interface, then it is working just fine. The issue is between the multilink and the target board.

    What debug shift frequency did you select, and what reset delay value did you use?


    Takao Yamada

    • Greetings,

      thank you very much for you help. It is working now. But dont know exactly why.

      After a reformat of the system i can flash it.

      Raphael Mencher

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement