Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
PROGHCS08 GO command not working after SD
Agostino F. Aug 30, 2017 at 07:00 AM (07:00 hours)
Staff: Takao Y.

  • Hi,

    I'm flashing an MC9S08SH8 with CPROGHCS08;
    the problem is that if I secure the device with "SD" command the software reset sequence "RE" and "GO" is not working anymore: I must power-cycle the board.

    Instead if I don't run the "SD" command than after "RE" and "GO" the MCU is alive and correctly functional.

    my actual sequence is like this:
    RE      ; reset MCU
    CM C:\PEMicro\PROGHCS08\Algorithms\9S08SH8.S8P   ; select algorithm
    EM      ; erase module
    BM      ; blank check module
    SS /PARAM0   ; select file to flash
    PM      ; program module
    SD      ; secure device
    VC                              
    VV /PARAM1   ; verify CRC
    RE      ; reset MCU
    GO      ; bring it to life

    Thanks for any help,
    agostino




    Comments

  • Greetings,

    The reasoning behind why RE and GO works without security is because RE actually does a software reset and re-enters debug mode. This is a problem if you secured the chip because re-entering debug mode would erase the flash of the device.

    Please go to support page -> Support requests and create a ticket for me. We can look into seeing if we want to repurpose the RE and GO to work in your situation.


    Takao Yamada

    • Thanks Takao,

      I'll do as you said.
      Regards,
      agostino

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement