Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
New Multilink Universal Not Working
Gerrit B. Aug 1, 2017 at 05:30 PM (17:30 hours)
Staff: Kevin M.

  • I'm running Windows 10, latest version, with auto-updating on.

    I replaced an older USB Multilink with a Multilink Universal, which arrived today. I followed the Quick Start Guide, installing software from multilink_universal_install.exe version 6.22.0.0 first, and then connecting the USB cable. I was not prompted for any hardware setup. Now no software recognizes the Multilink Universal, either my CodeWarrior 5.9 or my older Prog12Z. They both say there is no device connected, and the software often crashes when it tries to connect.

    I have unplugged/plugged the USB cable, rebooted, and checked Device Manager. The Jungo device driver shown there is "USB Multilink 2.0", driver version 12.4.0.0. There was also an older Jungo driver shown in Device Manager, "WinDriver", which I deleted. I replugged & rebooted after deleting the old driver, with no change.

    I have tried plugging the USB into a hub and directly into the laptop.

    My older USB Multilink worked, with this CodeWarrior and with Prog12Z. I was able to do code downloading, unsecuring, etc, but breakpoints weren't reliable. That's why I ordered the new Multilink Universal. But I can't get a peep out of the new device. The LEDs come on like they are supposed to, but no software communicates with it.

    Any clues or help?




    Comments

  • What a mess!  It is now working, but here's what I had to do:

    1. Repeatedly plug in the ML with Device Mgr open, and Uninstall each version of driver which showed up, selecting Delete Software each time. I had four or five of them stretching back several versions.

    2. When I re-ran the multilink_universal_install.exe which I just downloaded three days ago, it installed driver version 12.3.0.0 and Device Mgr said this was the latest and best version. Huh?

    3. I uninstalled this driver, and downloaded P&E Interface Drivers v12 from http://www.pemicro.com/downloads/download_file.cfm?download_id=53 . This is the link which shows up in FAQ #29.

    4. Run PEDrivers_install.exe. Now two drivers show up in Device Mgr: "USB Multilink 2.0" version 12.4.0.0 (the correct latest one) and something called "pemicrowindrvr".

    5. I now have two folders under C:\pemicro\PEDrivers: \Drivers_12_2_0 and \Drivers_12_4_0. Where did the _2_ version come from? It's not necessary, is it?

    6. Now at least my device is recognized by CodeWarrior.

    This is pretty miserable! I hope the thing works correctly and keeps working.

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement