Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
search inside all forums
Error in services launch sequence
Hector V. Jun 27, 2017 at 05:08 PM (17:08 hours)
Staff: Takao Y.

  • Hello,

    I'm using a U-MULTILINK UNIVERSAL Rev.C from some weeks ago and all has worked fine until past week. (programming with Kinetis Design Studio)

    Here the problem:
    I was debugging with the microcontroller MK10DX256VLH7 and I switched off the power supply before disconnect the comunication with KDS and, after that, I can't flash and debug with any of my PCBs with this microcontroller. I see always the same message from KDS:

    Error in services launch sequence.
    PEmicro GDB Launch Failure: The GDB Server was not able to establish a connection to the target processor. Please check your connections and power. Verify that the launch settings in the Debug Configuration are accurate.
    So, any idea? I can guess that I have crashed the u-multilink because after that fact I can't connect with any of my devices.

    Thanks in advance.
    Héctor V


    • I am also facing same problem did you find any solution ...Please let me know!! Thanks in Advance

  • Greetings,

    Do you have fresh silicon you can test against? See if this is a problem after you programmed the chip, considering this all worked before and it does not work now. Did you program any data between 0x400 to 0x410, which is where the security bytes are located and can cause the chip to be permanently secured?

    Takao Yamada

    • Thanks Takao for your reply. 
      I can guess the problem is located in the u-multilink because:
      - I had my board (personal board made by me) and I was programming it when happened the fact commented in my first comment.

      - After that, I thought that the microcontroller was secured (like you say) and for this reason I solded another PCB, the same model to try to program with a new microcontroller. And I received the same message, directly. So for me is the u-multilink the broken device.

      It's not obvious, only it's a feeling yet.

      Do you know if in some cases the u-multilink can broke if we cut the power supply while it is communicating with PC?

      I have not programmed any security flash. I was programming the SPI with one LCD, and some buttons through the chip 74HC165.

      So really I don't know what's going on. Any idea will be well comming.

      Héctor V

    • unknowingly i programmed some data between 0x400 to can i unlock my device now

      • Greetings,

        If you use PROG software and you cannot reconnected again, then there is not much you can do. If you are using KDS or S32 IDE then within debug configuration set the "mass erase" setting and start a debug session. If that does not work, then you permanently secured the chip. Get a new chip/board.

        Takao Yamada

  • Greetings,

    Do you smell anything burning or does the multilink get hot? If not, then I do not think there is any hardware components that were damaged. Disconnecting power is typically not a problem, but theoretically it could cause a surge. The only time you should not power down anything is when it is attempting to erase the flash of a chip, whether that is external or internal flash. This can damage the silicon or flash chip, but not the multilink or other PEmicro hardware interfaces.

    Does both LEDs still turn on? If you were to connect the ribbon cable on the target board, have you tried checking the voltages of the important pins like VDD, RESET, TDI, TDO, TCK? If you have a scope, does the voltage readings look fine to you?

    Takao Yamada

  • Hi Takao,

    Sorry for this delay. I was travelling for business...
    Ok, no smell so by now the U-MULTILINK we consider that it's fine.
    In fact, I can update it with PE-micro software: updater utiliy.

    As regard your questions: yes, both LEDs are working fine. Blue when I connect to the USB and the red when I supply my PCB.

    Regarding voltages:
    VDD = 3,31V
    RESET = 0.957
    TDI = 3.3V
    TDO = 3,53V
    TCK = 0.044V

    I think voltage in RESET pin is not enough high, isn't it?
    And the rest of voltages, what do you think?

    Today, I have tried to connect again to flash the new microcontroller but I receive: "DEVICE IS SECURE. ERASE TO UNSECURE?"
    And it's curious because this microcontroller is totally new. Its flash is totally clean because I haven't can programmed it.

    I hope your news.
    Thanks and regards.

    Héctor Vitales

  • Greetings,

    The software thinks the microchip is secured because it is not able to enter debug mode. So it wants to attempt to erase. But in reality, the problem is most likely hardware communication.

    Yes, the RESET voltage is too low. Did you measure the voltages with the multilink connected, or disconnected? Does it make a difference? If the voltage is low when multilink is NOT connected, then your board has a problem. You need to look at the schematic to find out why. This is most likely the main cause of your issue.

    Takao Yamada

  • Hi Takao,

    Yes, the issue is my PCB. I have 0,7V now in RESET pin when multilink is not connected.

    So maybe my microchip is dead because I gave him supply without the PULL UP resistor in Reset Pin. And now, with this PullUp I continous see 0,7V.

    It was my fault...

    Thanks Takao. If can't repair or find the problem I'll try to exchange the microcontroller by new one.

  • Hello again Takao.

    I've been researching and my fault was to put R=100k and C=10nF for power on Reset. "Device can't exit the power on reset (POR) event correctly with fast ramp-up slew rates."

    So now I have put R=6,8R and C=33uF and now the RESET pin is hold in 3V.
    So now my voltages are:

    VDD = 3,16V
    RESET = 3.07V
    TDI = 3.14V
    TDO = 0V
    TCK = 0V

    And the same error:
    Error in services launch sequence
    PEmicro GDB Launch Failure : The GDB Server was not able to establish a connection to the target processor. Please check your connections and power. Verify that the launch settings in the Debug Configuration are accurate.

    I have not made any change in code and any change in the configurations of kinetis design studio. So I don't understand where can be the problem.
    Any idea?

    With the oscilloscope the signals seems OK, no strange shapes.

    Thanks Takao, hope your advice.
    Héctor Vitales

  • Greetings,

    Those are just initial voltage values, which are important part of the following that is used to enter debug mode:

    a) RESET is driven low
    b) Activity appears of TCK, TDI, and TDO.
    c) RESET is released and go back high
    d) More activity on TCK, TDI, and TDO.

    Do you see these 4 steps occurring?

    Takao Yamada

  • Hi Takao,

    Yes! With oscilloscope I can see the next in the moment that I try to debug:

    - TDI a lot of activity
    - TDO a lot of activity
    - TCK a lot of activity

    The problem in the RESET PIN. I can see how the microcontroller try to pull down the signal but only down to 2,5V twice and finally it appears the error.

    Hope your news.
    Thanks Takao
    Héctor Vitales

  • Greetings,

    So that means RESET is not reaching 0V. You need to find out why based on your design, or the multilink is damaged. Do you have a reset circuitry that is competing for control over the RESET signal? Is the capacitor preventing your reset signal to reach 0V?

    What is concerning is this all used to work weeks ago, so why is this not working now? Did you make design changes on RESET?

    You may want to look into finding another multilink to see if maybe yours is damaged.

    Takao Yamada

  • Hi Takao,

    Exactly, I can see on the oscilloscope how the RESET signal reach 2,7V aprox but not 0V. And the same sympthom every time that I try to debug.

    I have tried with another multilink, a new one. And the same.
    I don't have specific circuitry for the reset. Only PullUp between 3,3V and RESET pin, and one capacitor between RESET pin and GND.
    I have tried different configurations:
    10k - 10nF = but in this case the RESET pin is always in 0V.
    56R - 33uF = reset pin is always 3V

    In any case, I can't connect.

    Weeks ago I was working perfectly with the same code and with any pull up and without any capacitor in reset PIN. I didn't have any problem.

    And suddenly, I can't. So strange but in internet I can find a lot of people with the same problem. But I don't find any solution.

    I'm really frustrated with this issue. I don't know if the problem is the multilink devices o my custom board.

    Any idea?

    Héctor V

  • Greetings,

    Remove the capacitor. Just have the pull-up resistor. See if this resolves your issue. The capacitor is the one preventing the circuitry to reach GND.

    Takao Yamada

  • Hello Takao,

    I have tried 10k resistor and any capacitor but the RESET pin remains always in 0V. So the same error.

    I have tried 56R resistor and any capacitor with the same result, no connection. But in this case the RESET pin remains in 3V.

    This board is totally new. I mean the microcontroller is blank.

    Thanks Takao,

  • Greetings,

    I want you to go to Support page -> Support requests to create a ticket. At this point the problem is very unique to your situation and not meant for discussion on public forums. In this new ticket, attach any relevant files like scope images, schematics, screenshots, etc. I will look for your ticket and pick it up from there.

    Takao Yamada

  • Thanks Takao.
    I have created this one: 25165

    I have attached files in there and some comments.


  • Same issue here. Did you find the solution?

  • Greetings,

    We were not able to reach a conclusion on this issue. If you have any resistors in series on RESET or any communication lines then it should be removed. Only resistors should be pull-up/pull-down.

    Takao Yamada

Add comment

   Want to comment? Please login or create a new PEmicro account.

© 2019 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement