Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept

search inside this forum
search inside all forums
Multilink Universal not recognized by CW V10.7 Special Edition
Isabelle G. Jun 15, 2017 at 03:35 PM (15:35 hours)
Staff: Johnny N.

  • I am using Special Edition: CodeWarrior® for Microcontrollers 10.7 (Eclipse, Offline) + P&E Multilink Universal rev D for a Cyclone V3 target.

    In the debug configuration, CodeWarrior sees the usb multilink as "Multilink Universal Rev ? (PEMEDCA1E)", when I launch the debug session I always get the same error from the P&E Connection assistant "An error occurred while connecting to the interface hardware or target specified in the Launch Configuration Dialog"

    This is what I tried to do to troubleshoot:

    - both LEDs are on on the PnE Multilink

    - Windows device manager > Jungo > USB Multilink 2.0 and WinDriver are both up to date and working properly.
    I uninstalled and reinstalled both drivers using the latest downloaded from

    - verified the BDM connections. TVCC=3.3V for my application

    Everything was working fine with an older Coldfire BDM interface "USB-ML-CFE Rev C", CodeWarrior could launch the debug session.
    But this device is now obsolete, and I had to order a Multilink Universal instead.

    Does anyone know if Multilink Universal is compatible with CW v10.7 IDE??


    • Isabelle,

      If Codewarrior sees a question mark in the debug configuration window "Multilink Universal Rev ? (PEMEDCA1E)", it means Codewarrior doesn't recognize which multilink it is.

      Please download our Firmware Updater utility for the Mulitlink Universal and make sure that it is updated to the ColdFire V2 9.81 firmware version.


      • After I install this firmware updater, Windows stops recognizing Jungo>WinDriver and Jungo>USB Multilink 2.0. They previously worked fine. They now have an exclamation mark "the digital signature cannot be verified". And Code Warrior crashes + closes as soon as I try to connect to target via Multilink.

        It looks like this utility has replaced my WinDriver with a new one that Windows did not like.

        When I uninstall this PEMicro firmware updater utility and reinstall my regular WinDriver, Windows is happy again.

        I am on Windows 10 Pro 64 bit.

Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement