Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
Cyclone Image Management Utility does not work anymore
Stephan D. May 31, 2017 at 06:45 AM (06:45 hours)
Staff: Johnny N.

  • Hello,

    after a recent firmware-upgrade of the cyclone max box (to 7.94) the cyclone image management utility (v 6.22.00.04) does not work anymore with this firmware on the cyclone max.

    The error is the following:

    - via USB -> Messagebox: "Cyclone information could not be extracted"
    - via Ethernet -> Status field lower left -> This interface is invalid.

    The Create Image Utlity does have the version 6.22.00.05, which does work with this firmware of the cyclone max box.

    The command line utility sap_launch.exe does work as well!

    Was the cyclone image management utility not updated perhaps to 6.22.00.05? I've downloaded Cyclone MAX Single File Installation (43949 KB) from the site.

    Best regards




    Comments

  • Stephan,

    With Ethernet, are you specifying the IP address of the Cyclone manually? Are you able to connect to the Cyclone via USB and via Ethernet with the Cyclone IP Config utility?

    Regards,
    Johnny
    PEmicro

    • Hi Johnny,

      sure I've specifed the IP of the cyclone. This has worked for over a year now until firmware update was executed.

      Like I said in my post - only the image management utility does not work with both connection methods, USB or NETWORK.

      • I'm sorry, I did not read your post thoroughly.
        I can in fact connect to the cyclone with the ConfigureIP.exe utility. Both ways, USB and NETWORK.

        • Ok I fixed the problem with USB.

          The network config with configureip.exe was mixed around. Strange settings in different fields. I've set the parameters for the ip and programmed it. Then I was able to connect with USB via image management utility.

          But the network method still says, that the network interface is invalid.

          • Stephan,

            It really shouldn't happen but it sounds like some of the Cyclone settings were already corrupted or got corrupted during the firmware update.

            Can you have Image Manager automatically detect the IP ofCyclone over the network (instead of specifying it)? I would like to see if it still gives the same error message.

            • I have the same problem with the universal programmer.  I can not use the image management program V6.22.00.04 to connect to the programmer via the network.  The Status message is "This interface is invalid".  However, I can connect to the programmer with the image creator program V6.22.00.05 via the network.

              Is there a resolution to this problem?

              Thanks,
              Joe.

              • Hi Joe,

                In your setup, is the IP address automatically detected by our Image Manager application or is it manually specified?

                Regards,
                Johnny
                PEmicro

  • Hi, I have exactly the same problem with "This interface is invalid" message while using Cyclone Image Management Utility. Is there a solution for this problem?

    /Markus

    • Hi Markus,

      In your setup, is the IP address of the Cyclone automatically detected by our Image Manager application or did you manually specify it? Are you able to connect successfully with USB?

      Regards,
      Johnny
      PEmicro

      • Hi Johnny,

        I have configured the Cyclone Max using the "Cyclone IP Configuration Utility". I have given it the IP 192.168.0.252 Gatway 192.168.0.1 and a Device Name of my choise. If I use the Cyclone IP Configuration Utility I can make it connect to the Cyclone MAX both using USB port and Ethernet Port.

        The "Cyclone Image Management Utility" works fine to retrieve the Image information using USB. When I try to Open with the setting set to Ethernet and the IP "192.168.0.252 : User Specified IP", then I get message "Status : This interface is invalid".

        What kind of interface is this application refering to? My feeling is that there is a mismatch with the firmware on the Cyclone and a driver or application on the PC.

        We have three PCs at our lab and we have this problem on two of them. If I move my Cyclone Max from a none working PC to the working one then it works fine. Conclusion is that the problem is on the PC setup and not on the Cyclone Max.

        We are working on moving to a Cyclone FX. We have not made it work yet (This is another issue :-). However I have installed Cyclone_universal and cyclone_control_package on at lease one of the none working PC´s. Now these applications are unistalled.

        Could the problem be because of the universal installer? And maybe the unistallation program doesnt clean up everything as excpected.

        So what do you think Johnny. Any ideas what the reason for the problem is?

        Regards
        Markus

  • Ok, I will do but what result came out from Support Request ID # 25281 that Joe applied for in August?

    Regards
    Markus

  • I've still got the problem as well in the Cyclone Image Management Utility.

    • There is a new version of the Cyclone Image Management Utility that should address this issue.

      Please open a support request ticket here to receive the file.

      http://www.pemicro.com/support/index.cfm

      • Thank you. The new version solved the problem.

        Regards
        Markus

      • I have created a SR. But isn't this going to be integrated in a new Package Download? We have to think about suppliers or partners, who will be using the product as well by our recommendation. I don't want to tell them, that they have to create an SR request in order to use the product properly.

        Best regards

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement