Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept

search inside this forum
search inside all forums
KDS updates kill the Cyclone Pro giving Module could not be erased.
Carl N. May 8, 2017 at 09:26 PM (21:26 hours)
Staff: Edison T.

  • Firstly, I have found many references to people with the same problem but PE micro keep telling people its their problem. This IS a problem with something wiht PE micro and it must be fixed. Everyone that has asked has given up and gone elsewhere!

    I have had everything working on KDS 3.1 using my Cylcone MAX for over a year straight on a dozen projects. Today I checked for updates, and found some, and did them, and it killed my debugger (just like it did a year ago)... Here is the log from the consol when trying to debug my KL27Z256M4. Note; I literally changed nothing, i checked all the settings and it seems fine, all projects now return the same error that were 100% working. You guys have stuffed something up in this.


    Connection from "" via
    Connection from "" via
    Successfully initialized kernel symbols.
    Copyright 2012 P&E Microcomputer Systems,Inc.
    Command Line :C:\Freescale\KDS_v3\eclipse\plugins\com.pemicro.debug.gdbjtag.pne_2.9.6.201704281541\win32\pegdbserver_console -device=NXP_KL2x_KL27Z256M4 -startserver -singlesession -serverport=7224 -gdbmiport=6224 -interface=CYCLONE -speed=5000 -port=USBĀ 


    Target has been RESET and is active.
    CMD>CM C:\Freescale\KDS_v3\eclipse\plugins\com.pemicro.debug.gdbjtag.pne_2.9.6.201704281541\win32\gdi\P&E\supportFiles_ARM\NXP\KL2x\freescale_kl27z256m4_1x32x64k_pflash.arp


    ;version 1.01, 07/31/2014, Copyright 2014 P&E Microcomputer Systems, Inc. All rights reserved. [kl17z_256k_n_pflash_m0]

    ;device freescale, kl27z256m4, 1x32x64k, desc=pflash

    ;begin_cs device=$00000000, length=$00040000, ram=$20000000

    Loading programming algorithm ...

    WARNING - Selected .ARP file has been modified. CRC16 = $BF3C
    Error loading CRC-16 algorithm.

    Error loading CRC-16 Algorithm.

    Module could not be erased.
    Error Erasing flash of device

    Error occured during Flash programming.

    PE-ERROR: Error downloading to the device.
    Disconnected from "" via
    Disconnected from "" via
    Target Disconnected.
    Target Disconnected.

    To replicate this fault, get yourself the KDS install and dont do the updates, make a simple project, debug and everything is fine, THEN, search for updates, do the updates, and your debugger will stop working.

    If there is a fix, please tell me because right now i ahve to uninstall everything and then install it all again and remeber not to do the updates.

    Come on guys, dont be lazy, fix this once and for all.


    • Hi Carl,

      I am having difficulty reproducing this issue. I started with KDS v3.2 and created/debugged a KL27Z project with a Cyclone MAX. After updating to the latest plugin, I debugged again and everything still worked.

      Could you point me to the other reports of users having the same issue?

  • So last night I uninstalled the driver by using
    When i reinstalled it (via installing KDS + Updates it works perfectly...)

    I had previously uninstalled KDS 4 times with the same result, however, after doing this uninstall the problems went away.

Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement