Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
Multilink ACP not detected by PE Firmware Update Utility nor IDEs but present in Device Manager
Francis C. Apr 25, 2017 at 06:46 PM (18:46 hours)
Staff: Kevin M.

  • Hello,

    We have just bought an ML ACP Rev A and and neither KDS nor CodeWarrior nor PE Universal Multilink Firmware Update and Architecture Selection Utility Version 6.22 detect it. Windows 10 Device Manager shows the Jungo Connectivity device USB Multilink version 2.0 12.4.0.0 dated 2017-01-11.

    Thank you




    Comments

  • Francis,

    Can you update to the latest version of the KDS plugin?

    www.pemicro.com/eclipse/updates

    The firmware update utility is not intended to be used with the multilink ACP

  • Hello Kevin,

    I have updated the plugin from 2.3.6 to 2.9.4, the GDB PE Micro Configuration icons has changed to a PE Micro logo but it still does not see it after restarting KDS.

    I can see under Jungo in Windows 10 Device Manager: pemicrowindrvr, USB Multilink 2.0 and WinDriver. I tried uninstalling and reinstalling the driver to no avail.

    thanks

  • What is the version of the driver installed for USB Multilink 2.0?

  • I can see the multilink acp rev a in version 2.94 of the plugin

  • The driver is 12.4.0.0
    I have managed to make it work on another computer. I'll try to find out what's wrong with mine.

    Should it work with CodeWarrior 10.7?

    Thanks

  • Francis,

    If you need it to work with code warrior you will have to manually update a dll or upgrade code warrior.

    If you would like that dll please email me at kevin (dot) meyer (at) pemicro.com

  • Hi Kevin,

    I tought it was working on my other machine but in fact, it's doing the same thing on bouth machines: upon connection, it can appear if I'm lucky enough to hit Refresh at the right moment but if it is detected and I hit refresh again, it's not there anymore. I know I have also been trying the GDB Server for Kinetis and also at first I had installed an older Multilink driver. I uninstalled those and rebooted since but could it have screwed things up?

    Thank you

  • I have uninstalled all PE software and drivers. Checked the also delete driver when uninstalling from Device Manager, unplugged the Multilink, deleted from the registry everything multilink or pemicro I could find, rebooted, installed Multilink drivers, plugged the Multilink and it worked.

    I'm good to go now.

    Thanks for your help.

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement