Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept

search inside this forum
search inside all forums
MultiLink RevD cannot enter the debug mode
. Apr 24, 2017 at 08:49 PM (20:49 hours)
Staff: Takao Y.

  • While Rev.C is working correctly, Rev.D cannot enter the debug mode for MPC57XX. I've tried with S32 using GDB and ICDPPC. It can detect the Multilink but could not connect to the microcontroller.


  • Have you tried updating your firmware to the latest version?

  • Greetings,

    Has this issue been resolved?

    Takao Yamada

  • Hello Takoa,

    I was using another Rev.C device at the moment, so I forgot to reply.
    Though I updated the Rev.D device with the lasted firmware, but still it's not working. And I've tested it with other MPC5777M EVB, but it was same.

    Thank you.

  • Greetings,

    One thing to try is swapping out the ribbon cable on the rev C onto the rev D. See if the cable is causing problems. It is the weakest physical link due to its bendy and flexible nature.

    If that does help, you will need to try lowering the debug shift speed in your debug configurations. On S32 you might find the option to be at 5000 khz by default. Try lowering to 3000 Khz and see if that works. Also try adding a 200ms reset delay. These 2 options are the first things I typically try when having difficulty connecting to the target board.

    Takao Yamada

  • Hi,

    I've tried what you suggested. But still it's not working.
    - The ribbon cable --> not working
    - Switching all options --> not working

    FYI, I'm using an EVB from NXP.


  • Greetings,

    You probably have a faulty multilink. Please go to Support page -> Support requests and create a ticket about this issue. Also update your PEmicro profile so that you have your contact information so that we can setup an RMA ticket to send your multilink in to us.

    Takao Yamada

  • Just an update. After re-installing the firmware(0981) again, I could enter the debug mode. Thanks.

Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement