Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
Unable to load debug information in ICD32Z
Steven W. Apr 14, 2017 at 01:40 PM (13:40 hours)
Staff: Mikhail A.

  • I'm working with a 68332-based system using GCC 6.1.0. I started with generating an ELF file, but got an error 103, which I determined was due to having debug information in the ELF file, because stripping debug information allowed ICD32Z to load the ELF file without problems.

    Using either the BETA/HLOAD sequence (from "P&E, GNU, and ELF/DWARF") or the HLOADMAP command (from "Debugging with C and ELF/DWARF" with a file containing only debug information produces the following:

    <path>\test.dbg detected as file type 'ELF/DWARF'.
    Error during load.

    The error is the same whether I compile with "-g" or "-gdwarf-2" in my linker options.

    What causes the "error during load" message, and how can I get source-level debugging working?




    Comments

  • Can I get some sort of response, please? Do you need further information? I'd like to get this problem solved.

    Thanks.

  • This issue was solved using a Support Request. The version Steven was using did not have support for his file type, but by upgrading to the latest version he was able to get the debugging support.

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement