Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
Problem programming devices with secure image using PROGACMP
Viktors S. Mar 30, 2017 at 10:31 AM (10:31 hours)
Staff: Takao Y.

  • Hi!

    I am currently developing manufacturing testing and programming application using PROGACMP. When I try to flash secure flash image and start device using GO or reset using RE it erases the device.

    I am using MULTILINK-UNIVERSAL with k22dx128m5 processor.
    Here is cprogacmp.exe produced log:
    CMD>EM
    Erasing. -Module has been erased.
    Reloading programming algorithm ... done.
    CMD>BM
    Blank Checking ... Erased.
    CMD>SS C:\mypath\Bootloader.srec
    CMD>PM
    Checking range of S records. -Checked.
    Programming. Address $ Processing Object File Data ... .... Programmed.
    CMD>VM
    Checking range of S records. -Checked.
    Verifying. Address $ 0000000000000140 ... 00005FD7. Verified.
    CMD>GO
    Device is secured. Erasing ...




    Comments

  • Greetings,

    Could you detail me which version of the PROGACMP software you are using?

    We made a change to RESET and GO commands within the last year that allows users to use these commands after securing the device.

    Originally RESET and GO was designed more for debugging purposes so the debug hardware would reset the device, re-enter debug mode, and then started your code. But if the chip is secured and you attempt to re-enter debug mode, that will erase the flash.


    Takao Yamada

  • P&E Interface detected - Flash Version 9.81
    PROGACMP 6.22.00.00

    We have only acquired license couple of weeks ago.

    Thanks!

  • Greetings,

    You are missing RESET command. After your verification please do a RESET to reset the chip and exit debug mode. That will resolve your issue.


    Takao Yamada

  • If I use "RE" command the result is the same:
    Or there is a different reset command?

    Log:

    CMD>VM
    Checking range of S records. -Checked.
    Verifying. Address $ 00000000 ... 00005FD7. Verified.
    CMD>RE
    Initializing. -
    Device is secured. Erasing ...Target has been RESET and is active.

    All programming steps completed.

  • Greetings,

    That is not suppose to happen. Could you go to Support page -> Support requests and create a ticket for me? I will forward your problem over to the ARM development team and have them look into this for you.


    Takao Yamada

    • Thanks. Ticket  24799 raised!

    • Any update on this.  I am have the same problem.  I purchased and downloaded the version from pemicro today, May 6.

      Don

  • Greetings,

    Issue will be resolved in the next release of the software. It has not been released yet. Still in testing and beta stage. I will update this forum when the next released software is ready.


    Takao Yamada

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement