Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
Stuck on Loading programming algorithm
Markus O. Mar 23, 2017 at 09:38 AM (09:38 hours)
Staff: Takao Y.

  • Hey PEmicro,

    I am trying to program my SPC5602D microcontroller through your USB Multilink Universal FX.
    As software I am using PROGPPCNEXUS.
    During start up the software will detect the programmer with the connected microcontroller, but when I am selecting the programming algorithm the software seems to stuck on in state "Loading programming algorithm" for minutes...hours...days...eons :-D

    If I watch TDI, TDO, TCK and TMS I can see that these signals are toggling.
    There are also two times low level at reset line, first about 100ms, then approx. 1,6s toggling at JTAG, then about 100┬Ás low level and more toggling at JTAG.

    I can abort the loading with ESC, but I am not able to erase or program the controller with the software.

    Is this a known issue? Can you help me?

    Thank in advance!

    Markus Oberle




    Comments

  • Greetings,

    Before you click on the "Connect" button in PROG, try lowering the debug shift frequency to the slowest option. Then attempt to load the algorithm. If this works, then start using faster and faster options until you are stuck again loading the algorithm. Every customer's setup is different so you will need to use trial-and-error methods to find the best speed to communicate to your target.

    Also try adding a 200ms reset delay. This helps with any reset circuitry you may have on your board.


    Takao Yamada

  • Greetings,

    Any update on this?


    Takao Yamada

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement