Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
Flash even without 3.3V on Cortex Plug Pin1
James S. Feb 15, 2017 at 08:10 AM (08:10 hours)
Staff: Takao Y.

  • Hi,

    I noticed when programming my K22 on my board an error $0007 appears immediately when pressing the start button on my Cyclone_ACP. Temporary resolution was to make a connection on my board between the cortex plug's pin 1 and 3.3V on board.

    Since many PCBs have already been created my question is whether it is possible to persuade the Cyclone to still do it.

    Regards
    James




    Comments

  • Greetings,

    To be able to provide power to target, you need to do 2 things:

    a) Make sure you have the proper jumper settings on your cyclone ACP. Please read the manual to learn which jumpers to set.

    b) Within your image you need to set it to provide power to target and specify the voltage.

    Once you set these 2 options then the power will turn on when you press the START button.


    Takao Yamada

    • Hi,

      Thanks for your reply.

      Maybe I wasn't very specific. The board is self powered. If I connect the PCB with the Cyclone nothing will be indicated on the Cyclone's display.
      If I make a fix on the PCB and connect the Cortex Pin 1 with the PCBs 3.3 V and connect it again, the Cyclone indicates that it is connected to a chip.

      I read the part in the manual about jumpers and from what I understood Jumpers 3,2,1 have to be set. This was not successful and so I did even try all presented combinations without having the PCBs board powered thru Cyclone Power Out Jack because I don't have a power supply handy to plug into Cyclone's Power In.

      The dirty fix would be that a connection from PCBs 3.3V will be connected directly with the Pin 1 on Cyclone's port B. However using a different programming device I was able to program the microcontroller as is.

      On the PCB this pin is not connected to anything.

      Regards
      James

  • Greetings,

    Even with the jumper settings, you need to set in software to provide power to target (even though TVCC on pin 1 is not connected). In image creation utility you should see this option. This allows the cyclone to know that the reference voltage of the target board is 3.0V.


    Takao Yamada

    • Wasn't aware of that. Using Cyclone Relays, target voltage set to 3.0 Volts and with the jumps set this works. Many thanks.

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement