Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
ML Universal Rev A Drivers and Resource CD for ML Universal and ML Universal(FX)
Donald P. Jan 28, 2017 at 04:00 PM (16:00 hours)
Staff: Takao Y.

  • I now have ML Universal Rev A and a ML Universal Rev C.  I had some problems so I removed or renamed all files that were PE.  I then downloaded the Resource CD for MLU and MLU(FX) and installed the software. I read somewhere that these drivers are not for the Rev A and I will have to down load the drivers for Rev A.

    Rev A seems to work with the CD Software but with some problems. Rev C does not work. I am using CW 6.3 on a XP computer. In Hardware Manager in Jungo folder I now have WinDriver. Before I had two items in Jungo. I prefer to use Rev A and keep Rev C as a backup. Do you think the Rev A drivers were not in the CD software and that I need to download the Rev A drivers?




    Comments

  • Greetings,

    Not sure where you read that the drivers are not for rev A, but that is incorrect information. The resource CD has two things important: USB drivers, and updated firmware. The USB drivers are all the same no matter what hardware or operating system you are working on. If you use the firmware updater utility found on the resource CD, then you will have the ability to connect to either multilinks and force update to the latest firmware.

    If CW6.3 has issues, it is most likely because you have not patched up your software yet. Please use this FAQ to find out information on which patch and how to get it done:
    http://www.pemicro.com/faqs/faq_view.cfm?id=211&menu_id=faqs


    Takao Yamada

  • Greetings,

    Is this issue resolved?


    Takao Yamada

    • Hi Takao,

      Problem not solved. I have spent so much time on it I have had to catch up on some other things. When the Rev A device appears to function it will not properly debug assembly code that uses the X register. I'm thinking the problem may be with Code Warrior 6.3. When I can get Rev A to sort of work the Rev C device will not work at all. It gets in a loop of, unplug USB cable, try to reconnect to target, unplug USB cable. I'll give a more detailed description later today or tomorrow.
      I will also remove and reinstall Code Warrior and see if there is a change before I contact you.

      Don

  • Greetings,

    Any new information to help us debug this problem?


    Takao Yamada

  • Hi Takao,  With my most humble face I must say that a small amount of knowledge can at times take you a long way down the wrong path.  For many years I had never used the H register in HCS08 programs, and then I did.  Little did I know that when using the X index register that the H register would be an active part of the X register.  Loading #$00 into the X register certainly does not clear the H Register and loops may go just about anywhere if there is something left in the H register. 

    With only one version of the MLU firmware running and that being the latest and with the patch for XP, both Rev-A and Rev-C devices are working fine and I have a backup MLU. Thank you for your time and please excuse my learning experience. I certainly know your produce better now.

    Don Pierman

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement