Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
Stand-Alone Programming not working with Cyclone ACP
Jack D. Jan 26, 2017 at 12:01 PM (12:01 hours)
Staff: Edison T.

  • Whenever I try stand-alone programing with my Cyclone_ACP I get "Error $00000007".  I can use the PROGACMP (progacmp_cyclone.exe) program and run each instruction individually and everything works fine. However when I use ImageCreator with the exact same settings and procedure, load it onto the Cyclone and try stand-alone programming I get the error. Why is that?




    Comments

  • Greetings,

    I am glad you knew to try out the PROG software first to help you debug the problem. Now we can start looking at what configuration and settings you are using in your SAP image to figure out this problem.

    Could you tell me the following information:
    1) Which chip are you trying to program?

    2) Are you using SWD or JTAG? Did you make sure to select the right protocol in the image creation utility?

    3) What setting did you select for debug shift speed? Did you put any reset delay?


    Takao Yamada

  • Thanks for your quick response.
    1) I am trying to program a Texas Instruments LM3S9B96

    2) In the image creation utility I am using JTAG. Target board is JTAG 10 pin. Does image create utility use the same JTAG protocol as PROG or are their differences?

    3) In image creation utility debug shift speed is set to "3 - Shift Frequency = 4.55 MHz" (I have also tried "0 -Shift Frequency = 10.0 MHz ")
    And in the PROG its set to "(3) : Shift Frequency = 4.545 Mhz" which works
    I have no Reset delay, The Drive RESET signal LOW before and after SAP operations is unchecked. The target is powered separately, not by the Cyclone.

    • Hi Jack,

      For #2, can you confirm that you are also using JTAG in PROGACMP? In PROGACMP, this setting is controlled by the "Use SWD reduced pin protocol for communications" checkbox. You would leave it UNCHECKED to select JTAG.

      For #3, try an even slower Shift Frequency in the Image Creation Utility to see if it makes a difference.

      Best regards,
      Edison

  • Okay, So I do check off the "Use SWD reduced pin protocol for communications", and that implies that I am using SWD and not JTAG.  Thanks for clearing that up!

    I switched my image creator to SWD with the lowest shift frequency(0: 10.0MHz)and it works now. Thanks again.

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement