Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
MC68HC908GP32 Can't pass security feature in monitor mode
ff f. Dec 30, 2016 at 05:38 AM (05:38 hours)
Staff: Johnny N.

  • Hello,

    I have big problem.. JUst bought 3 pc brand new MC68HC908GP32CFB..
    i made a programmer like on this site "http://www.not2fast.com/megasquirt/megaprog/megaprog.pdf";

    Every thing looks to be allright. i COnnect via COM port on my old PC, choose 19200baund and class 1 motorola ICS with DTR. The Prog08sz "talk" to MCU by first attempt, but i can't pass security bytes. Have try FF also 00 nothing work.

    and now 2 quesitons:

    1. In the prog08sz v2.36 there is a status information listed in 6 points on the bottom of window. (Attepmting to contact target window)
    There i have:
    0. Hardware loop back detected: Y
    1. Device echoed some security bytes: Y
    2. Device echoed all security bytes: Y
    3. Device signaled monitor mode with a break: Y
    4. Device entered monitor mode: Y
    5. Reset was POR: Y
    6. ROM is accesible: N

    We can see only the ROM is not accesible becouse is secured.
    ???DId the status 0-5 can tell me that my programmer works properly and tehre is no transmission errors????

    2. When i set option " IGNORE security failure and eneter monitor mode"

    The prog08sz looks like do connect to MCU, i specify programming algorithm 908_Gp32.08p and on my status window i can see"
    "INITIALIZING. (Bus. Freq. = 4917khz) initialized.
    ;version 1.10, 11/11/2002, Copy right......
    ;device Freescale, 908_Gp32, All
    ;Begin cs
    Loading programming algoriothm ... Done."

    ?? is that programming algorithm loaded to RAM memory in MCU ??

    When i use command SM show module as start adress &8000 every where is "AD"

    I try to erase module EM command to set the security bytes to default FF, even if the chips are new and should be blank.

    After use EM command in the status window i can see"

    "Erasing. Wrasure of secure device done. Forcing Power down to bypass security.
    starting powerdown reset sequence...
    Trying security &FFFFFFFFFFFFFF Acces denied.
    (68hc08 device responded properly, but ROM is secure)"

    The time since i use EM command to starting powerdown reset sequence is very short like 0.1s instant.
    Again i have to set IGNORE securitry pass failure to enter the monitor mode but memory is still secured.

    Any ideas how to solve this problem and get this MCU work and programming????
    The EM erase module command is the same as MASS erasure routine ????

    Best regards.
    Chriss




    Comments

    • Greetings Chris,

      Please make sure that the pins used for entering monitor mode are configured correctly. This is our recommended connections to the GP32 if you were using one of our programming interfaces.

      PORTA7, PORTC0, PORTC1 and PORTC3 are used for entering monitor mode. By default the user may directly bring these signals out to the target MON08 Header.

      Alternatively, the user may pull down PORTA7 and PORTC1, pull up PORTC0, and pull up/down PORTC3 for clock division. In which case the user does not need to connect these signals to the target MON08 Header.

      If you read $AD from the chip, that means you failed to bypass security and the flash is still secured. If you don't know the security bytes, you can still bypass security by mass erasing the flash but you need to have high voltage on IRQ. Can you verify the voltage of IRQ when you are entering monitor mode and during erase module?

      Regards,
      Johnny
      PEmicro

    • Hi Chris,

      Were you able to get your board working?

      Regards,
      Johnny
      P&E

  • Hello Johnny.

    That for your reply.

    No i still not able to get my board work.

    I have build the programmer like on this PDF file " http://www.not2fast.com/megasquirt/megaprog/megaprog.pdf " - page 18.

    I use caned 9.8304Mhz oscylator. have check the connection as your recomendation and every thing is connected correctly. PORTA7 IS LOW, PORTC1 IS LOW PORTC0 IS PULL UP 5V AND PORTC3 is also connected to choose the 19200 baund.

    My "HIGH" voltage on the IRQ pin is:
    1. Programmer board is connected to power supply and COM port, but prog08sz software is not started. IRQ pin = 7.90V
    2. I start prog08sz software. When the programmer board is active (class 1 - motorola ICS board (power controlled by DRT)). IRQ pin voltage drops to 7.77V.
    3. When i set IGNORE SECURITY BYTES and enter the monitor mode with secured flash voltage on PIN IRQ remains 7.77V.
    4. When using ERASE MODULE command voltage on PIN IRQ remains 7.77V

    • Hi,

      0. Hardware loop back detected: Y
      1. Device echoed some security bytes: Y
      2. Device echoed all security bytes: Y
      3. Device signaled monitor mode with a break: Y
      4. Device entered monitor mode: Y
      5. Reset was POR: Y
      6. ROM is accesible: N

      Based on these results, you are communicating properly with the GP32 micro.

      Seems like a IRQ/VTST issue. According to data sheet, "Monitor mode entry voltage VTST must be VDD + 2.5 to 9 V". Maybe your VTST is just too low since its right around the threshold.

      Also make sure you have pullup resistors on PTA0 and RST.

      Regard,
      Johnny
      PEmicro

  • Hello Jhonny..

    I increase the IRQ voltage too 8.5V at entry monitor mode and during erase try.

    And this does not help. Still can not pass the security code and also, i thing cant erase module properly.

    • Hi,

      One other thing I would check is to make sure you have pullup resistors on PTA0 and RST. The signals should be close to VDD when high and 0V when low.

      I ran some tests on one of our GP32 evaluation boards so I could be absolutely sure the software worked. I can get pass security mode and erase fine. However that uses a standard MON08 debug port.

      Regards,
      Johnny
      PEmicro

  • Hi,

    If i can ask, what is your PC specification witch you use to connect the GP32 ?? And what OS you use ??.

    I notice that it could a problem with new nad middle old computers.

    I Try run this on W10 I5core and on XP intel dual core 2ghz, both are not working.

    I send one chips that i tested to my friend, he have the same programmer board but very old PC Celeron 733 with XP OS. And he programmed this chip fine.

    • Hi,

      I have a PC running Windows 7 x64 with a Core i7-4790 3.60 GHZ processor. I'm not using a COM port though. Did you try other baud rates?

      I'm also sending you the latest version of PROG08SZ 5.74.

      There are utilities out there that can reduce the speed of a processor to run older programs. That might be worth a try if the issue is related to processor speed.

      Regards,
      Johnny

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement