Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
programming a s -record file
PREETU ABRAHAM K. Dec 15, 2016 at 07:08 PM (19:08 hours)
Staff: Takao Y.

  • I want to program a s-record file(.sx file) generated from CodeWarrior for HCS08 Processor  using the csaphcs08z by using a batch file through a Configuration file .It stores the image to cyclone pro but the hardware is not able to retrieve the image from cyclone pro. Whether csaphcs08z or proghcs08 is needed for programming the hardware for HCS08 through cyclone pro.




    Comments

    • The Configuration files and batch script used for programming the device can be shared.

  • Greetings,

    When calling CSAP, what commands are you using to load the image to the cyclone? You need to specify the interface, port, filename, and other parameters to load the image onto the cyclone.

    I am sending you our documentation on CSAP so you can learn how it is done.


    Takao Yamada

    • Hi, I tried this in configuration file : but still not able to program it even though it programs I am not able to read CRC and serial number through RS232



      RE ;Reset

      CM C:\PEMicro\cyclone_pro\supportFiles_HCS08\9S08GT60A.S8P
      SS C:\cdss_lrsa_op_sw_loader\xxx.s19

      PM ;Program Module
      VM ;Verify Module
      EM
      BM
      PM
      PT
      VC


      and in the script file

      echo -----------------------------------------------------------
      echo Programming Operational Software into Unit, please stand by
      echo - If programming is successful, this box will just go away
      echo - Otherwise, it will report the problem
      echo -----------------------------------------------------------

      CSAPHCS08Z.exe INTERFACE=CYCLONEPRO PORT=USB1 xxx.cfg


      I am basically trying to read CRC from .s19 file at FFC0 location through RS232 interface

      Whether the .s8p files can be changed .SINCE THE 2004 VERSION WAS DIFFERENT WHEN COMAPRED TO 2009 VERSION

  • The hardware is not getting information from Cyclone Pro .I am using now a Windows 7 64-bit machine, Previously the project used a XP machine. I am able to download to cyclone Pro as it shows successful

  • and the image file generated is from Code warrior 10.6.5

  • Greetings,

    I am not understanding your CRC question. There is an option to return a CRC of the S19 file on the display of the cyclone, but not at a specific address or through the RS232.

    If you can download your S19 successfully to your chip on the cyclone, then that is all that the CSAP utility can do for you.


    Takao Yamada

    • Thanks Takao for the reply .

      I am not sure whether the chip has been downloaded with .s19 file, since once after downloading we try to retrieve the CRC data (from the .s19 file embedded in it) through RS232 interface.

  • Greetings,

    Debugging a scripted programming is going to be difficult. I highly suggest you learn to use the PROG software found in your cyclone software package. For you that would be PROG for HCS08. Use this to load the same algorithm and S19 and see if it programmed correctly. Then try to replicate the success in standalone programming.

    Within PROG HCS08 software, you can use the show module command to see if the CRC data exists where you think it is.


    Takao Yamada

    • OK thanks for the reply ,Can you please share a similar file which you had shared for SAP

  • Greetings,

    There is no file to share. Within your cyclone software package, you have all the documentation you need to learn how to use the PROG and other cyclone utilities.


    Takao Yamada

  • OK thanks Takao

  • Hi Takao, 

    I am able to program through to the Cyclone pro without connecting to target but when done through the target is not able to receive the image data

  • Greetings,

    First of all, were you ever successful flash programming using our PROG software? Remember how I mentioned that you must get it working on PROG first before attempting SAP. Do this first and if you can get that working, then replicating it in SAP is very simple.


    Takao Yamada

  • Yes it worked it shows programmed for a .s19 file which was generated some few years back


    But I have a clarification for the image file ,I generated through code composer recently I have a .sx file and a .abs.s19 file .But there is no option to select a .sx file even though it is an s-record file

  • One more Query when I just check my cyclone pro to see whether it has a status of image file loaded ,it shows 0 bytes. And when I click on Launch programming ,it shows error $ 000000007 ,something like that

  • Sorry it shows error $00003003

  • Greetings,

    We filter your file choice by file extension. What you can do is when the prompt shows up, type in *.* and all files will show.

    Do you have the exact same files, algorithms, and settings in your image that you created compared to what you have done in PROG software?

    Error $3003 is program operation failed. If you look back at your configuration you made for your image, you used the PM command before you did a EM command. PM means program. EM means erase. You are erasing after you are programming your device. You have to have the correct order of commands.


    Takao Yamada

  • Hi Takao,
    ok will check that *.* extension.

    We have the same set of files, algorithms. The difference in PROG software there is no .cfg file


    basically, There are two cyclone pros .One which is with XP and other one which I am trying to configure is with windows 7 .So the one with XP has a SAP exe file of 2008 dated which works in XP and loads the image into target. The other one with Windows using the new SAP exe is not working

    yes in the example I put EM commands but this is .cfg file which I ma using


    RE ;Reset

    CM 9S08GT60A_op.S8P
    SS cdss_lrsaS1_OP_SW.s19

    PM ;Program Module
    VM ;Verify Module


    and the script for batch file is

    csaphcs08z.exe INTERFACE=CYCLONEPRO PORT=USB1 cdss_2500_op_loadS1.cfg

    but I feel it is getting loaded into cyclone pro(Since it shows the open window and done) but from cyclone pro don't know how it loads into target after that

  • Greetings,

    What I am saying is that your configuration does not erase before programming. This is why you are getting the $3003 when you try to execute the image. Just put the command EM before PM and you should have no problems.


    Takao Yamada

  • Hi,

    I tried EM before PM ,still it loads the image to cyclone pro but the target does not get the data

  • Hi Takao,

    I got it to work with PROG software now should try to do it with SAP one

  • Hi Taka,

    It is not coming with SAP

    These are the commands


    csaphcs08z.exe INTERFACE=CYCLONEPRO PORT=USB1 xxx.cfg

    In cfg


    CM 9S08GT60A_op.S8P
    SS xxx.s19

    EM ;Erase Module
    PM ;Program Module
    VM ;Verify Module

  • Greetings,

    Instead of trying to use CSAP, first could you use the image creation utility. It is a utility found in the cyclone software package. This should be used instead of CSAP. Only use CSAP when you want to automate creating of the image, and we are not at that point yet. You need to get this image working first.

    There are other settings and configurations other than the commands that you need to be setting correctly to avoid all of the problems you are facing.


    Takao Yamada

  • Yes, I think there are few more settings while using csap and image creation utility. Since it can store the image to cyclone without being connected to target. But I am not sure what are the settings which is needed so that target gets the image from cyclone and target is not able to retrieve it

    But I was able to get it working with PROG Software and it works only when target connected

  • Hi Takao,

    In continuation the above mail ,I got the image loaded into cyclone Pro using image creation utility and then in the cyclone pro device I programmed it with connection to target still present, now the target has got the image


    I would like to know the commands after loading the IMAGE TO CYCLONE PRO using CSAP and Image creation utility ,what needs to be done for the target to get it without manually using the cyclone device for programming

  • Greetings,

    What you should do is once you have all of the commands and settings completed in the image creation utility, go to the File Menu -> Save configurations and you will have a CFG file you can use with CSAP to load the image automatically onto your cyclone.


    Takao Yamada

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement