Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
Dead of 3 Multilink Universal
Roberto G. Nov 30, 2016 at 08:12 AM (08:12 hours)
Staff: Johnny N.

  • Hello everybody
    I'm using this product since 3 years. I flashed and tested a lot of projects without a problem, but in the last year I damaged (I don't know how) 3 Multilink Universal. I can access the devices (two are Rev C and the latest is Rev C.2) using Firmware Updater Utility and the devices are enumerated and the blu led is on. So I think that in every case the MCU that resides on Multilink is not damaged. When I connect my target board the yellow light is turned on: but when I run my debug session and CodeWarrior tells me that cannot comunicate with P&E device. If I use a new Multilink it works fine so is not a software problem but an Hardware issue.
    In one of the three cases I get U9 very hot and I have to remove from USB the device. It happen when I start debug session and I think that MCU on Multilink try to communicate with the targed. I don't notice any abnormal current consumption. I can't understand what happen.
    I tried to change some components on the Multilink but I didn't fixed the issue.
    I would like to know if the problem could be the MCU on the Multilink: i think that if MCU is "dead" or broken then Multilink cannot communicate with the PC. I think that the problem could be on the buffers U4 U9 U10 U11 and U12, or maybe on the switch U3 (references are for the C.2 version).
    I'm very worried about this because I've damaged 3 Multilink and know I have the latest one and I NEED it to contniue my project.
    I hope I have explained clearly the situation.
    Can anyone help me?
    Excuse my poor english.
    Best regards
    Roberto




    Comments

    • Hi Roberto,

      I'm very sorry about the trouble you're experiencing with our tools. Your English is fine and you have clearly explained your issue.

      The Multilink typically fails when it is subjected to a high voltage and current that exceeds the limits of the components on the interface circuitry. This will cause blown components or internal shorts to power or ground shorts that result in excessive current draw. The high voltage/current can come from a bad power supply on your board, static electricity, or poor grounding issues.

      What target microcontroller are you programming?

      Whats the system voltage of the target board? Does the board have its own regulated power supply?

      Are you using any custom connectors/adapters/cables to connect the multilink to your target board?

      Regards,
      Johnny
      PEmicro Engineering Support

      • Hi Johnny
        I use the programmer with differents type of microcontroller. For example I use MKE02Z64VLD for one project, MKE04Z128VLH4 for another one and MKE02Z32VLC2 for the third.
        All of these projects uses 5V as power supply and targed board has its own regulated power supply.
        I use a custom connector and cable, a little wired board for connecting Multilink to my own boards (all of them have the same six poles connector).

        My target boards are usually powered by a battery system, and I think the matter is grounding difference between PC an battery System. In the past with similar features I've never experienced any trouble.

        Now I'm trying to replace all integrated circuits on Multilink except the MCU: I think that if Multilink can communicate with PC and execute upgrading firmware procedure, the problem can be solved changing buffers. I hope it, because so I can recover at least one of the pieces.

        If you have any idea of tests that I can do, please don't hesitate and tell me!

        Regards,
        Roberto

        • Hi Roberto,

          Please open up a support ticket under Support tab -> Support Requests -> Report a Product Bug or Problem. I will provide you with a list of components that you can try to replace.

          Regards,
          Johnny
          P&E Engineering Support

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement