Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
search inside all forums
Jeremy B. Oct 31, 2016 at 04:28 AM (04:28 hours)
Staff: Mikhail A.

  • Hi,
    Im having a few issues tried to read the external flash of a board I have. Its a MPC561 and Spansion S29CD016J. I try and connect using the external flash module but it wont connect. I have tried lowering the speed to no avail. I have tried accessing the internal flash but there is no MPC561 module. I have had some success using the MPC563 and more so the MPC565 module. I can read the internal flash with the MPC565 and it seems to connect the best (but not everytime) but when it doesn't it has the PCP errors (as the external flash drivers do).

    I am using a USB-PPC-BDM cable. Is there something you can recommend? I'm not so worried about reading the internal flash and writing it, more so the external flash. I have tried to blank the internal flash and it also fails.



  • Dear Jeremy,

    Some initial things that we can check:

    Please try updating the drivers from our website:

    Have you tried replacing the ribbon cable between the multilink and the target? It is often an issue in connection problems.

    How are you powering your target?


  • I am running the latest drivers. The ribbon cable is brand new. The target is powered externally. I have tested with another BDM (very cheap and crappy) and it works but I much prefer your software and cable so would like to use it :)

    Its like nothing can be loaded to 0x00302000 (all external flash algos) but loading to 0x003F9800 (internal MPC565 512k flash algo) is fine?

  • Dear Jeremy,

    Are you still experiencing this issue?


Add comment

   Want to comment? Please login or create a new PEmicro account.

© 2019 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement