Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
OSBDM communication to TRK-USB-5604B board
Duane M. Oct 2, 2016 at 05:28 PM (17:28 hours)
Staff: Takao Y.

  • I had a TRK-MPC5606B setup and working with CodeWarrior for MCU (V10.6), but I took that kit to work.  The TRK-MPC5606B is on backorder, so I purchased the TRK-USB-MPC5604B board to use at home.  After rebuilding my project for the different target (5604B),  I expected to be able to use the same RAppID Bootoloader utility to load the firmware on to this board, via OSBDM, but I could not establish communication with this board, (it's a bare board without the tower system).  So I downloaded all of the installation software from

    http://www.nxp.com/products/software-and-tools/hardware-development-tools/startertrak-development-boards/mpc5604b-startertrak-usb-development-system:TRK-USB-MPC5604B?fsrch=1&sr=3&pageNum=1

    including CodeWarrior V2.10, but that didn't solve the problem, even after uninstalling and re-insalling all of the USB drivers.

    I then downloaded OSBDM from
    https://www.pemicro.com/OSBDM/
    as they have an update that is suppose to work with Window10 which is what I'm using, but I still can't establish communications with the TRK-USB-MPC5604B.

    The USB device drivers are all registered correctly in the device manager (Jungo/WinDriver, OSBDM Debug & Serial ports). And I am setting J3 Pins1&2 so that the bootloader is started once I press reset. And I have verified that J6 & J7 are set for pins 1&2 for TX/RX to USB. As I stated, this worked for the TRK-MPC5606B board, so I had expected RappID bootloader to work the same way for this board. I do have the osbdm_pemicro tools installed, including osbdmtester.exe, but I don't see my target in the list of options (CF, CFV1, S12, S08, RS08, DSC), and the documentation provided for this utility is sparse. I tried writing to flash, but just get 0000 when I check that location.


    So my questions are:

    a) is there anything else I can try to try to get this board to work via USB/serial/BDM?

    b) is there a more detailed manaul for the osbdmtester.exe utility?


    I'm guessing that either I damaged the hardware or that the OSBDM was not installed or corrupted. I do have access to USB Multilink for Quorivva, which I can use in an attempt to recover the board, but for $25, I don't know if it is work digging into those details, as I've already spent more time then I had wanted. I had expected the board to be plug-n-play after getting the TRK-MPC5606 up and running.




    Comments

  • Greetings,

    If you do not have the J3 pin set, do you see your board? I first want to see if you can see your board outside of bootloader mode. By setting this pin and powering up the board, you are in bootloader mode and will only be able to change the firmware of the OSBDM. Not your 5604B chip. You really should only have to update the OSBDM firmware once in its life-time.


    Takao Yamada

  • I don't have the board with me at the moment, but typically I power the system with J3 open (no jumper on pins 1&2).  The USB enumerates the board and I can see it in the device manager.

    I then do the same thing that I had done previously for the 5606B-board. I start RAppID Bootloader utility, after configuring it with a rbl file for the appropriate COM port as shown in device manager, I press "Start Boot Loader". Then I place a jumper on pins 1&2 of J3 and press the RESET pushbutton, and then continue with the Windows dialog message. At this point RAppID BL Tool times out. I get nothing in the Trace.

  • Greetings,

    With J3 open, are you able to flash program the board? I just want to make sure the basic OSBDM functions are working.

    Without the bootloader utility, if you put the J3 jumper and connect it to the computer, are you able to see the bootloader show up in device manager? It should show up differently as "bootloader" and not as "OSBDM debug and serial". If this is not working, then nothing in the RAppID utility is going to work properly.


    Takao Yamada

  • When I connect with J3 open, I see OSBDM debug & serial.
    I've not attempted to flash the board with J3 open.
    I'll try it tonight. Thanks for the suggestion.

    I had presumed that it would work the same as the TRK-MPC5606B board. With that board, the jumper is installed to get to the alternative boot mode, but it won't enumerate in the mode. Since the TRK-USB-5404 board was enumerating (Windows USB device manager), I'd assumed that J3 open was the correct way to power it up, and J3 pin1&2 was used to flash it.

  • Takao, thanks again for you help.

    I connected the USB cable with the J3 jumper in place and I can see "Open Source BDM-Bootloader Port under LibUSB-Win32 Devices in the device manager. There is no "comm port number associated with this".

    If I then unplug the USB cable; remove the J3 jumper; and reconnect the USB cable, I get OSBDM/OSJTAG - Debug Port under LibUSB-Win32 & a separate OSBDM/OSJTAG CDC Serial port under (Ports), which is what I expect. But when I run RAppID Bootloader Utility, and attempt to flash using the serial port, (adding J3 jumper and pressing reset), I get a "BAM Communication Error (Loss Communication with BAM at Password. Check that PassWord is connrect. Supported Baud Rates: 66B70."

    I'm using COM3: 9600, MPC5604/3P, BAM enabled, default password, Flash\MPC5604B.mot file, Erase and Program.

    I will mention that I actually have two separate RAppID BL installed in separate location: Version 1.6.7.35 (build 20 Nov 2015), and Version 1.6.3.16 Build 28 Oct 2013. Both yield the same response.

    I recently damaged the 5V supply on my TRK-MPC5606B board while probing the power supply voltage, so getting this board up and running is now more important and I'll be taking it to work with me to work on.

    I can send you screen shots and files if that is of importance. I think I have device driver conflict. I am using Windows 10 and I did in stall the Windows 10 update for the OSBDM.

  • Greetings,

    When in bootloader mode, there is no com port associated with it. That is expected behavior. Only the OSBDM firmware application has that ability.

    You really should not be needing to put the J3 jumper. That is for making changes to the OSBDM firmware and cutting off communication to the MPC5604B device. The RAppID bootloader you are trying to program is into the Qorivva device itself, am I correct? You are not trying to overwrite the OSBDM firmware?

    I am not very familiar with RAppID but are you suppose to be connecting via serial port? Is there no way to use the OSBDM debug USB interface to program your MPC5604B device? For example, if you go into Codewarrior software and you try to program the the 5604B via OSBDM you should be able to program and debug it.


    Takao Yamada

  • Takao,

    Correct. I am not trying to overwrite the OSBDM firmware.

    "RAppID bootloader utility" is a serial port communication device for updating application software in the target, using the OSBDM bootloader. On the TRK-5606B board, there is a jumper that select the "alternative boot", which then boots to the bootloader (BAM=boot assist module).

    I'm guessing that the TRK-USB-5604B board does not have this "BAM" "alternative boot" capability. From what you are telling me, I should not need to use the J3 jumper, since I want to program the application software.

    If that is true, then I need to figure out what software to use to upload new firmware to the TRK-USB-MPC5604B board via the OSBDM serial port. Maybe there is a PEmicro application that I've overlooked. I guess I need to download the pemicro_osbdm_osjtag_tower_toolkit.exe as discussed in the following forum topic. I'll try to read up on it to see if it is what I need to use.

    http://www.pemicro.com/forums/forum.cfm?forum_topic_id=4069

  • Takao,

    I believe the TRK-USB-5604B board does not work the same way the TRK-5606B board works. I don't see any way to program it as a stand-alone device using any of the OSBDM tools over USB. Those tools appear to be for application serial communications online and not for firmware updates. This is unexpected as I was hoping to use it in a way similar to the TRK-5606B board, which does use OSBDM for firmware updates.

    I do have a USB Multilink Universal that I use for the MCP5602B. There is an appropriate 14-pin JTAG hearder on the TRK-USB-5604B board, so perhaps I can use the multilink device to update the firmware. I'll give that a try next.

  • http://cache.freescale.com/files/microcontrollers/doc/user_guide/TRK-USB-MPC5604B_UM.pdf state on page 11, "The TRK-USB-MPC5604B includes P&E’s OSJTAG circuitry, so no external Qorivva hardware tool is needed to debug and program the TRK-USB-MPC5604B."

    But I've not found any documentation that explains how to program it via the USB connection. I was able to use a MultiLink Universal connected to the JTAG port to program it.

    So my question is: Is there documentation on how to program the TRK-USB-MPC5604B target via OSJTAG circuitry? It's lot clear to me to the documentation that I've been able to dig up and it is certainly different from the TRK-MPC5606B devices which uses the alternative boot (BAM) to program the device.

  • Greetings,

    Programming via USB is by selecting OSBDM as your interface when flash programming, and making sure debug is showing up under Jungo in device manager. And you can update the OSBDM bootloader (not RAppID) by setting the jumper and loading a new OSBDM firmware.

    However, your question is different in that you are trying to use RAppID boot loader to load a bootloader into the target and not into the OSBDM firmware, which is maybe something you need to work with NXP support team in getting this working.


    Takao Yamada

  • Takao, thanks for the comments.

    I've been able to get around the problem by using a MultiLink Universal on the JTAG port to program the device. I just thought that I would be able to program it using OSBDM and the RAppID Bootloader Utility, because that is the way the TRK-MPC560xB boards work. But I guess that would require using the FAB (force alternative boot) jumper which this board is not setup for.

    Regarding programming via USB using OSBDM, yes the debug is showing up under Jungo in the device. I'm using CodeWarrior for MCU (V10.6 Eclipse). I can attempt to use CodeWarrior to program the device directly instead of using the RAppID Bootloader Utility, but I'll have to figure out how to set that up. I'm sure there is some documentation on it that I can find if I search for it, but if you know of such a document, I'd appreciate a link to it. I'll dig into it this weekend.

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement