Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept

search inside this forum
search inside all forums
Multilink universal - error 0x8882
Nivedita A. Aug 3, 2016 at 12:16 AM (00:16 hours)
Staff: Takao Y.

  • Hello, I recently bought a Multilink Universal Rev C. When I tried to debug it with the Freescale Code-warrior version 2.9 for the controller MPC5567. It has been posting the error 0X8882 : Flash erase failed. I tried with Windows XP and 7.

    I have been using previously Multilink Universal Rev B for the same code and device on Windows XP platform (since 2014).

    Please provide if there are any patches need to be installed for using it for windows XP/7.


  • Greetings,

    Did you make sure to run the firmware updater utility that was in the CD that came with your multilink? Without that, the multilink universal is probably running firmware that supports the ARM architecture, not PowerPC Nexus. Please update your firmware and try again.

    If you misplaced your CD, please download it here:

    Takao Yamada

  • I tried using it after installing the utilities provided in the CD but the same error persists.

  • Greetings,

    I want you to try installing the latest patch I have created to support the latest hardware and support for Codewarrior classic:

    Download the support for Qorivva patch and see if this improves your setup.

    Takao Yamada

  • Greetings,

    Any update on this?

    Takao Yamada

Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement