Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
USB-ML-UNIVERSAL updated and failed
VINCENT . Jul 13, 2016 at 06:09 AM (06:09 hours)
Staff: Kevin M.

  • After updated, USB-ML-UNIVERSAL's red led flashes 3 times and then green led 
    flashes 3 times, failed.

    How to do it?

    thank you.




    Comments

  • Vincent,

    Sorry for the late reply. Were you able to resolve your issue?

    My suspicion is that your multilink may be damaged.

    What rev is your multilink? the lights should be orange and blue.

    Best,

    Kevin

  • Hi, 

    I recently updated the firmware of our Multilink Universal FX. After the update the device is dead. The update program does not detect the Multilink Universal FX any more. I updated it with the "PEFirmwareUpdater.exe" aplication provided with the driver installation program, the one shipped with driver version 12_3_0 (download today).

    Hardware description:
    - USB-ML-UNIVERSAL_FX, rev B
    - Platform: Coldfire MCF5275
    - Windows 7 64 bits

    Detailed description:

    1- The Multilink Universal FX was working perfectly with windrvr6.sys V11.7.0 and a patched CodeWarrior 5.9.0

    3- For other reasons, I had to reinstalled the PE-micro driver, so I downloaded it from your web today. (multilink_universal_install.exe, file version 5.48), which installs PE-micro drivers 12.3.0 and windrvr6.sys V11.7.0

    4- I used the PEFirmwareUpdater.exe shipped with the installation program to update the multilink FX firmware.

    5- The update program correctly detected the multilink FX and the platform ColdFire 123 processor, so I proceeded to do the update. The program says it will update to file usbmlfxufcfens.0960, I think. I didn't pay much attention on this.

    6- The update finished correctly, and a green button showed up in the update program saying the update finished successfully. After the update leds were blue an orange, respectively.

    8- Then, I tried to connect to my platform using the Code Warrior, but it didn't connect.

    7- So I unplugged the multilink and plugged it again from the usb, and tried again the firmware update program. But now it does not detect the multilink-universal-FX at all. Leds are blue and orange, but it doesn't detect the programmer hardware, as it did before the upgrade.

    So it looks like the firmware upgrade dead locked our multilink-FX.

    Any suggestion?

    Any

  • Pedro,

    Sorry for the delay in response, did you end up resolving your issue? My suspicion is you will need a replacement.

    Best,

    Kevin

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement