Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
Short with the multilink universal PE micro when the port 6 JTAG is connected to a board of mine
Emile L. Jun 28, 2016 at 03:29 PM (15:29 hours)
Staff: Johnny N.

  • Hi, 

    I've been using the PE micro multilink universal to debug a board of mine since few days. Everything worked fine until yesterday. For no reason, now, when I connect the 10 pins port 6 JTAG to my board and I power my own board with a power supply, the power supply shorts and the yellow LED never go on. My computer still recognizes the PE micro and when I switch my PE micro with my partner's one, with the same board, everything goes fine with his gear. So, it's not a driver problem or a problem with my own board. It's probably a hardware problem with my PE micro. Am I the only with this problem? What can be done? Is there a warranty on this Pe micro? Is it possible to send it to a repair center? If not, Which components on the board should I test first? Can I have access to PE micro schematics?

    Thank you




    Comments

  • Sorry, It's not the port 6, but the port G. Looks like a 6 on the board

    • Emile L.

      Based on your description of the problem, it sounds like there is a short on Port G Mini 10 header across the target power and ground rails. When you connect the multilink to your target board, this short causes a huge current draw on your power supply.

      There is currently a zener diode T2 that protects the multilink from over voltage situations.

      If a voltage exceeding 5.6V for a signficant duration is put on the pin, the zener diode will fail and sometimes short to ground. I think this may have occurred with your multilink.

      Can you remove T2 (on the right side neat Port B) and check if the multilink is still operational? Hopefully the diode prevented the rest of the circuitry from getting damaged.

      Regards,
      Johnny
      P&E

      • Hi John, 

        I watched the component T3 (I suppose that it's a zener diode like T2) and it is shorted. Can I simply remove it too? Should I replace it? What's the part number?

        • T2 is the same zener diode for the RESET line. If it is also shorted, you should remove it and recheck the Multilink.

          • I removed T3 and it worked!! But what's the part number of T3 so I could replace the diode for more safety?

            • Hi Emile,

              T2 and T3 are 5.6V 500 milliwatt Zener diodes with the part number MMSZ5232B-7-F

              -Johnny

  • Hi John,

    Thank you for your response. Your right, there a short between the power and the ground. It is probable that I put more than 5.6 volt on my board for some testing. I removed the zener diode, but the problem is still there(still a short between the ground and the power) ... Do you have any other idea for what's going on? Is it possible to have access to the schematics?

    Emile

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement