Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept

search inside this forum
search inside all forums
Jeff H. Jun 8, 2016 at 04:15 PM (16:15 hours)
Staff: Kevin M.

  • Hi, I've tried installing the two software discs that came with my USB Multilink Universal FX, and I've also tried downloading software drivers from your website, and neither of them allowed me to activate my programmer on a Win7 machine.  The programmer is not recognized, the blue light does not come on, and only the driver shown is the WinDriver under the Jungo device.  I attached the device to the PC prior to installing the drivers on the machine.  I also may not yet have full network permissions for the machine.  Please tell me what's going wrong.


  • The programmer was also previously installed on another machine, but it was supposively deactivated on that machine.  Could there be an issue recognizing the activation code and machine name?

  • 1. Were there any errors on the installation of the drivers?
    2. Do you have any other P&E Hardware interfaces so that you can test the drivers on them?
    3. Has this programmer worked on other machines?



  • 1. No.
    2. No.
    3. Yes. We bought it just a couple weeks ago, and it easily installed on that machine.

  • Is the multilink plugged directly into the PC or are you using a hub?

    Try plugging into different USB ports that are connected directly to the PC

  • It was plugged in directly to the PC.  I tried a USB port on the monitor to a 1 foot cable.  I also tried connecting to the front port of the PC on a 3 foot cable.  I also tried connecting to another port on the front of the PC on a 1 foot cable.

  • OK, I was able to plug the programmer into another computer, with possibly different administrative priviledges than the first one, but now the software can not activate.  I know it's connected because the blue light turned on.  Can we reset the activation code or remove software on the other computer to complete the installation?

  • We got the right administrative priviledges and we can now complete the software installation.

Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement