Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
Unsecure S08SG8 with CyclonePro under Win7 64-bit
Tian M. May 6, 2016 at 01:06 AM (01:06 hours)
Staff: Takao Y.

  • Hi, 
    Can I unsecure S08SG8 with CyclonePro under Win7 64-bit?
    Thanks
    Oliver




    Comments

  • Greetings,

    Operating system does not matter.

    Cyclone pro can unsecure the 9S08SG8. But note that unsecuring means erasing the flash. That is the only way you can unsecure and be able to reuse the chip.


    Takao Yamada

  • Hello, Takao
    Can you explain the steps of using cyclonePro to unsecure S08SG8?
    Thanks
    Oliver

  • Greetings,

    Sure! There are 2 ways you can unsecure the chip.

    1) PROG software
    If you use our software to connect to the cyclone then to the chip, it would detect that your chip is secured and prompt you if you wish to unsecure/erase the chip. If you click ok then it would proceed and you can then program a new program using the commands found in PROG.

    2) Standalone
    You can load an image into the cyclone with commands and your binary and when you execute the image it will auto-detect a secured chip and auto-unsecure/erase the chip for you so that it can program your binary files and execute any other commands you have setup in the image.


    Takao Yamada

  • Hi, Takao
    I tried these two method but failed.

    Method 1.
    "HCS08 Programmer" will hint that can't connect with target then stopped.

    Method 2.
    error code 0008 which is 'Error entering debug mode while target is secured'

    Can you check these steps?
    Thanks
    Oliver

  • Greetings,

    Then there is most likely a communication issue. You should check the schematic to see if there are any external watchdog or other circuitry on the BKGD or RESET line that may cause issues talking to the chip.

    From what I read in the manual, there is no permanent secure of the chip, so you should be able to unsecure the chip with no issues.

    A few things to also try is to make sure you are using the latest cyclone pro software and firmware. I do not remember any bugs related to this, but maybe it may resolve itself in an update:
    http://www.pemicro.com/products/product_viewDetails.cfm?product_id=1


    Takao Yamada

  • Greetings,

    Any update on this?


    Takao Yamada

  • Hello, Yamada
    The chip had been sent back to factory and will be checked on ATE.
    Thanks
    Oliver

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement