Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
Cyclone MAX: DSC MWCT1001 Program + Verify OK, but program is not running
Toni S. May 2, 2016 at 09:21 AM (09:21 hours)
Staff: Takao Y.

  • Hello everybody,

    I have a Problem with my Cyclone MAX Programmer when programming a DSC MWCT1001.
    I use the newest Firmware Version 7.92-6.2 and the Image Creation Utility 5.77.0400. The Interface is JTAG/ Port B.

    I can download the Image on the cyclone without any problems. Also the steps "program module" and "verify module" are carried out successfully in Stand alone Mode.
    But when I shut down the supply voltage of my target and turn it on again, the program of the DSC is not runnig. I also tried to make an Reset/ Delay before programming and a GO command after programming.

    Note: I cant perform an Erase Module- Step, then I have an Error 2003.

    The same procedure I can carry out with a CYCLONE UNIVERSAL. The Steps here are the same: Program modul, verify module.
    Here the program of the DSC starts after a reset of the target.

    The only difference is the following: When I connect to the target, the program asks "the device is secured. Erase to unsecure?"
    When I click YES the chip is erased and after that I can start the programming procedure.

    When the Problem with the cayclone max is the secured device, then maybe I have to erase the device before programming. But that isnt possible, as I wrote above.

    I´m not shure what I can do else...




    Comments

  • Greetings,

    Where are you seeing the dialog that says "the device is secured"? This is obviously not in standalone with the cyclone universal. Are you using PROG? If so, what happens if you connect the cyclone max to the same PROG software? Are you able to flash program and see your program run?

    I am trying to do 2 things here:

    a) Make sure your cyclone max is in working condition. Since cyclone universal seems to work fine, do the EXACT same test with cyclone max to confirm the problem is not hardware failure.

    b) Differentiate results between standalone and use of software. If it works in software, great! But we need to focus on standalone after you confirm that both cyclone max and cyclone universal work in software. Let us not mix results.


    Takao Yamada

  • Greetings,

    One more thing I want you to do is program your device using the max and use the PROG software for your chip and use the upload module command. This reads the flash contents and dumps them into an s-record file. Repeat the test with your cyclone universal and compare the two files. Are they the same?

    Do this test using the PROG software to flash program and also when doing standalone programming. This will help you in figuring out if any data is truly missing in flash that is causing your issue.


    Takao Yamada

  • Greetings,

    I´ve just programmed the device with the Cyclone MAX using the PROG Software and everything works fine, so the behavior is the same as from the cyclone universal.

    I also uploaded the s record file from the Flash after Stand alone programming and after the PROG-programming. The files are completly different...

  • So is there any difference between Stand alone programming/image and the programming process of the progdsc_max.exe  Software of the Cyclone MAX?

    I always perform the same steps:

    CM
    SS
    PM
    VM

    After I used progdsc_max.exe the correct program is located in the Memory and it works correctly.

    But when I program via the SAP Function using the Image on the cyclone max the Software on the chip isnt running. There is no error message while programming.
    But according to the s-record files,the content of the Memory in this case is different to the content after the programming via the progdsc_max.exe.

    It seems that the sap Image does something else...

  • Greetings,

    Yes the process is different but the results should be the same. So if there are differences, then we must find it and find out why. This is why I am asking you to run the tests I have asked.

    Could you create a ticket by going to Support page -> Support requests and upload the s-record files (with descriptive file names) of PROG and Standalone. I would like to see the differences and have our DSC expert take a look.


    Takao Yamada

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement