Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept

search inside this forum
search inside all forums
Unable to program kinetis S9KEAZ128A using multilink universal and Codewarrior
Giuseppe C. Apr 21, 2016 at 05:26 AM (05:26 hours)
Staff: Gerardo R.

  • Hello to everybody,
    iìm trying to programm the NXP micro S9KEAZ128A using multilink universal and Codewarrior (10.5 and 10.6 ), but during flash programming, appear this msg and program aborted
    Starting 3rd party flash programming...
    INF: Copyright 2012 P&E Microcomputer Systems,Inc.
    INF: Command Line :"C:\Freescale\CW MCU v10.5\eclipse\..\MCU\bin\de.exe" -noni -language en -ORBendPoint giop:tcp: -ORBtraceLevel 0
    INF: Initializing.
    INF: Target has been RESET and is active.
    INF: CMD>CM C:\Freescale\CW MCU v10.5\MCU\bin\Plugins\support\arm\gdi\P&E\keaz128m4_pflash_pipeline.arp
    INF: Initializing.
    INF: Error loading .ARP file : C:\Freescale\CW MCU v10.5\MCU\bin\Plugins\support\arm\gdi\P&E\keaz128m4_pflash_pipeline.arp. Set PC and Run Error.
    ERR: Error loading programming algorithm - load aborted.
    ERR: Error occured during Flash programming.

    how can i do?
    i have connected only 3 SWD pins +gnd + vcc 3.3V
    please help me


  • Can you verify that your setup works on a FRDM or TWR development board? This will help narrow down the issue.

    • Hi,
      my setup works perfectly with demo board TRK-KEA128 using open SDA protocol
      Friday, my colleague tried with his pc and the same codwarrior, ad all seems to working well. So there is somthing on my mc/driver.
      So i have unistalled all and re-install codewarrior and driver, but the problem remain

      help please

      • Did your colleague use the same ribbon cable and Multilink as well?
        Are you both on the same version of CodeWarrior (and completely up to date)?
        In your device manager do you see an entry for "Jungo" and underneath it "Windriver" and Multilink 2.0"?

  • Hi to everybody an P&E.
    I have found the problem.

    The problem is that using Codewarrior (every vers.) no correct fw debug was loaden into micro. So following you can find a "working" solutions for debug kinetis.

    1) install on pc KDS 3 IDE
    2) use an empty project to connect the first time with Multilink and Kinetis
    3) power on DUT
    4) start debug and test it is running.
    5) stop debug WITHOUT remove power to dut
    6) open Codewarrior (every vers. ex.10.5 or 1.6 or 10.6.4)
    7) start debug configuration and all works fine.

    now you can start and stop debug everytime you want, but do not remove power on DUT. If you nedd to do this, you have to repeat from 2)

    ... this works, but is "terrible" take opened 2 big application for using only one

    please take a solutions

  • Our Kinetis Recovery Utility may have the same effect that you are finding with CodeWarrior. This type of workaround becomes necessary when your application disables the SWD pins early on.

    • Hi,
      i have just tried your software but it doesn't work.
      The effect is the same, SWD protocol doesn't start .
      Only using kds first, Codewarrior is able to connect to kinetis.


  • Hi,
    KRU worked great for me. Many Thanks!

    John G.

Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement