Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept

search inside this forum
search inside all forums
UNIT12z Library Routines - Cable Error
Michael S. Apr 14, 2016 at 12:47 PM (12:47 hours)
Staff: Takao Y.

  • Hello,

    I have purchased and been attempting to use the "unit_12z.dll" to connect to Multilink Universal Rev. A. I have been able to confirm opening the port using the appropriate routines. However, after resetting the cable interface, I am always getting a cable error returned. I have tried to connect to the BDM ports on two different types of targets and always experience a cable error.

    I am having difficulty finding resources that address what types of problems cause the cable error and how I can successfully enter background mode after opening the port from my program.

    Additional Info:
    - Both LED indicators (blue and yellow) are illuminated on the Multilink.
    - The Multilink has been verified to work properly in other contexts.
    - The targets have been verified to work properly in other contexts.



  • Greetings,

    With your purchase of UNIT12Z, you should have been given the Delphi20 and msvc50 projects. Try running those examples (test12z.exe) and see if you are able to detect your multilink. Then once confirmed, use the code example to figure out hwy your code is giving you cable errors.

    Takao Yamada

    • Takao,

      Thank you for your reply.

      I've confirmed that the multilink is detected in the test12z.exe example. Using the code example, I have verified that the port is able to be opened and am able to reset the cable interface but I receive the "Error resetting hardware interface" due to a cable error.

      I can't see anything in the code example that will indicate why a cable error occurs, only that it occurs.

      I have confirmed that I have a good connection with the multilink using various other methods. Is there any reason I should receive a cable error other than broken connection or power? It seems that there is another reason lurking.


  • Greetings,

    You indicated the multilink and target has worked in other contexts. What are those contexts?

    The check_cable_error and reset_cable are specifically to the P&E interface, not the target. Somehow there is an issue communicating to your USB Multilink. Is there any unique setup you have that you have not mentioned? Like a USB hub, USB isolator, virtual machine, USB analyzer, or other connection between the UNIT layer and the multilink hardware?

    Takao Yamada

Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement