Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
USB Multilink Universal with Error Message "Failed to resume target process"
zhen wei r. Apr 11, 2016 at 10:03 AM (10:03 hours)
Staff: Takao Y.

  • Hi

    We have used your USB multilink BDM to debug Freescale 9S08GB32 processor with Code Warrior V10.6 running with Windows 7 in our 3 labs for over 2 years. All the USB multilink BDM modules work well so far.
    Recently, we bought a USB mutilink Universal BDM to replace the USB multilink BDM because of out of stock of the USB multilink BDM in digikey.ca.
    When I start debug mode in Code Warrior V10.6, I got message popped up, "Failed to resume target process. Downloading binary to target..."
    With this error message, I can do some debug only and some functions in Code Warrior are not available. It seems some thing wrong with the multilink Universal BDM.
    I am pretty sure that the driver for the USB multilink universal work normally because it is the one in the CD which comes with the package of the brand new BDM module.
    Thank you for helps in advance.

    David Ruan




    Comments

  • Greetings,

    1) Are both blue and yellow LED lit on your multilink universal?
    2) Which revision of the multilink universal did you get?
    3) If you installed the CD, use the firmware updater utility and make sure you can see the multilink universal and can change the firmware to support the HCS08 architecture. NOTE, this utility is ONLY for multilink universal. Not for USB ML 12.

    4) Are you using any unique setup like custom ribbon cables, adapter, or anything else connected between the multilink and the chip? Are you connecting all 6-pins of the BDM, or have you hand selected which pins to connect?


    Takao Yamada

    • Hi Takao,
      Following are the answers to your question:
      1)   Both blue and yellow LED lit on
      2)   Revision of the multilink universal: Revision C
      3)   When I use the utility for firmware update:
      Device: Multilink Universal Rev C [PEM68FCA2]
      Architecture: RS08/S08/S12[X][Z]/ColdFire+/ColdFire V1
      Feedback: firmware update success
      4)   Using only the 6-pins ribbon cable which comes with the multilink universal

      Thank you.

  • Greetings,

    A few more questions or suggestions:

    5) Do you have an external clock/crystal? If so, what is the frequency, and what is the bus frequency of the chip you have it set to?

    6) Upgrade your Codewarrior to be version 10.6.6, which is the latest. Rev C of the multilink came out when CW10.6.4 was released. Even though this multilink should work fine in backwards compatibility, you may want to see if the cause of the problem due to old bugs or lack of features.

    7) Create a brand new project for the 9S08GB32. Without making any changes to code or configurations, just simply try to compile and debug the project. Does it work?


    Takao Yamada

    • Hi Takao,
      Thank you.

      5) Not sure.
      6) We are use Special Edition Code Warrior Version 10.6 in our labs. This is a free version. I can not find version 10.6.6 on the Freescale website. Is the version 10.6.6 a free special edition software?
      7) Trying brand new and simple project with the USB multilink Universal: not work and same problems

      Any other suggestions?

  • Greetings,

    You just have to update your CW10.6. Go to the Help Menu -> Check for Updates.

    The next thing you need to do is start getting an oscilloscope and checking the BKGD and RESET lines. Compare between the older multilinks and the newer one and see what are the differences. Let me know of your findings.


    Takao Yamada

    • Hi Takao,

      What have been done here:
      1)CW v10.6 updated, problems same
      2)Download CW 10.6.4, installed, and updated, problems same

      Can you send me the link for Code Warrior v10.6.6?

      I got a diagnostic file from the code Warrior and I want to send it to you.
      Please give me your email address.

      Thank you.

      David Ruan

  • Greetings,

    There is no link to v10.6.6. You simply check for updates like I mentioned before.

    Please go to Support Page -> Support requests to be able to share any files. You cannot do so in this forum and I am not going to disclose my email as I already get enough emails internally. I will find your support ticket once you submit it.


    Takao Yamada

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement