Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
USB Multilink Undetected. Code Warrior Cannot Debug.
Bernat B. Apr 8, 2016 at 04:46 AM (04:46 hours)
Staff: Takao Y.

  • I cannot debug in Code Warrior (v10.2) with P&E Micro USB Multilink Interface (QORIVVA for MPC55xx/56xx) on a Windows 7 64-bits. 

    When running Debug in Code Warrior, I get the message "Failed to resume target process., EPPC GDI Protocol Adapter : Can't connect. The Debugger can not connect to the P&E device".

    Also, Multilink device is NOT detected by P&E Firmware updater software, even the drivers USB Multilink 2.0 and WinDriver appear in Device Manager and the Blue LED is on.

    I tried on 2 PCs (both Windows 7 64bits) and Firmware Updater does not recognize the USB Multilink device neither of them.

    Please could you advice me on solving this issue?

    Thanks




    Comments

  • Greetings,

    I do not think the issue that the PC cannot detect your multilink. I think the problem is your multilink cannot detect your target, or at least cannot communicate to it

    1) Let us first confirm you got the right firmware update utililty:
    http://www.pemicro.com/downloads/download_file.cfm?download_id=335

    2) Which chip are you trying to connect? If you are using MPC5775K, then you will need to know the default censorship password. I can let you know if that is the case.

    3) Right click your project -> Debug as -> Debug configurations... -> Edit connection and see if you can see your multilink when you have interface as multilink.

    4) Try lowering the debug shift speed/frequency. It is an option found when editing your connection.

    5) Do you know if this chip is blank? Or it has been programmed in the past. I ask this because it is possible previous users has censored the chip and you will need the password to be able to flash or debug the chip.

    If you still cannot connect to your target, then I would suggest 2 more things:

    a) Upgrade your Codewarrior to version 10.6.6. This is the latest version and you should try using the latest when possible.

    b) Get an oscilloscope and start probing the signals. Find out which signals are not toggling. Let me know what you find.


    Takao Yamada

    • Hi,

      1) I downloaded the firmware link, but after following the instructions, this means copying the USBMLPPCJTAG20_ENS.508 & USBMLPPCJTAG20_REF_ENS.508 files to C:\PEMicro\multilink_universal\ and to C:\PEMicro\firmware_updater\, I still cannot see my device in Firmware Updater.

      2) We are using a Freescale SPC5604CML (MPC5604P target). This is a blank chip that has never been programed before. As you say, it is asking for a password. By defaulr it shows "FEED FACE CAFE BEEF".

      3) In Debug Configurations, yes, I can see "USB1: USB-ML-PPCNEXUS Rev A (PE8018256)" in Port field.

      It seems that the device is OK and I need the censorship password.
      Could you please provide this password to us?

      Thanks

      Best regards.

  • Greetings,

    There are 2 occasions when the censorship prompt shows up:
    1) Your device is indeed censored and although FEED FACE CAFE BEEF is the default password it is not working for you. But blank chips do not have default passwords unless you have the MPC5775K device.

    2) Your multilink can detect your target but it has issues communicating to it. It thinks your chip is censored, but it may not be at all. I think this is what you are experiencing. Therefore you still have issues between the multilink and the chip.

    3) Please uninstall the multilink universal software/utility. You do not have this device. This is why it cannot detect your qorivva multilink. It will only confuse you.

    Let us go down a different route to help you firmware update and try connecting to your target device OUTSIDE of Codewarrior. The following test is more low level and it can help determine the real issue.

    a) Download the following trial software we have for PowerPC Nexus:
    http://www.pemicro.com/downloads/download_file.cfm?download_id=194

    Use the PROG for PPCNEXUS software and try connecting to your target with your multilink. If your multilink does not firmware update, that is fine that means you already have the latest version we offer. Try lowering the debug shift option as you attempt to connect. Let me know what you find.


    Takao Yamada

  • Hi,

    I downloaded PPC Nexus software and run 'PROGPPCNEXUS - Flash Programmer'. It recognizes the USB-ML-PPCNEXUS device and it does not show any option to update firmware. I tried several Debug Shift Speed options and none of them connects to the target.

    If I connect a MPC5604 development board as target it connects correctly, but not to my board with the blank MPC5604.

    I noticed that in 'Target CPU Information -> Advanced' I can specify the uncensor password. Shall I enable this option and try here the default password 'FEEDFACECAFEBEEF'?

    Best regards

  • Greetings,

    Again, blank chips DO NOT need a censorship password unless it is MPC577xK device. I only mentioned it because you did not tell me which chip you were working with in your initial post. Just ignore I ever mentioned it because it is not going to be helpful at all in your situation.

    Your multilink is fine. No need to firmware update. Your board is not fine. Start comparing the schematics between the development board and your new board and see what differences you see. Start making changes and figure out which signal lines were giving you troubles. Also consider if your chip is bad as well and maybe replace it.


    Takao Yamada

  • Hi,

    You were right: it is a problem with the board. We tried with a second board and there it works fine debugging with Code Warrior. It should be a problem with our first board.

    Thanks for your help.

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement