Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept

search inside this forum
search inside all forums
FRDM-KL46Z is bricked! Help!!
. Apr 3, 2016 at 07:57 PM (19:57 hours)
Staff: Zahar R.

  • So I loaded a .s19 file onto my microcontroller because it said that it was an update. Now it will only boot as a bootloader. Tried to update the bootloader and the firmware using these instructions,

    but nothing is working. Any ideas on how to completely wipe the hardware and start over or just how to get functionality back??


    • One more thing is that I have tried to transfer files over on 2 different OS's, Mac OS X, and Windows 10.

      • Hi,

        Is the board's green LED blinking at about 1 Hz indicating that it is in bootloader mode?

        Download our zip file containing all of our OpenSDA MSD Applications:

        Extract the FRDM-KL46Z MSD App and then copy and paste it into the Bootloader drive. I recommend that you do not drag and drop the file into it because this has failed for me in the past.

        P&E Engineering Support

Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement