Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
U-MULTILINK-FX & DSC 56F8345 problem
Arcangelo P. Mar 25, 2016 at 09:27 AM (09:27 hours)
Staff: Takao Y.

  • Hello,
    Today I wish to dismiss my 10 year old USB TAP.
    I want ti use U-MULTILINK-FX in a custom electronic card with 56F8345 processor.

    I use codewarrior 10.6 on a Win7 64 bit OS. I have an old project that I can successfully debug with USB TAP.

    Now I installed and updated the new U-MULTILINK-FX.
    I done a new blank project.
    In the new project I copy->paste the processorExpert beans and the sources code from the old project to the new empty.
    I can successfully compile the project.
    In my project there is no watch-dog.
    I'm not able to debug my project there is this problem:
    "Failed to resume target process.
    GDI Procotol fatal error: : An error occurred while trying to read memory"

    Can someone help me?

    ARC_




    Comments

  • Greetings,

    If you use a blank project and without making any code changes are you able to flash and debug your device? If not, then we need to start from there.

    Note, that the USB ML Universal FX is very fast interface, while the DSC is not so. What you may need to do is lower the debug shift frequency within debug configurations. Right click your project -> Debug as -> Debug configurations. Then find the "edit connection" button and lower the shift frequency to option 22, which is around 1 Mhz. Then try again.


    Takao Yamada

    • Hello Takao,
      thank you for your fast reply.

      During my tests I do that:
      1) new Empty project: I can launch debugger and I can run/stop the empty main() function.
      2) I copy --> paste the ONLY beans from old projet to the new project: I can launch debugger and I can run/stop the empty main() function.
      3) I copy --> paste the source code: I can launch debbugger only 1 time... and not in right way... after the first time... I always get the same error during the "Path remapping"
      --> I read something in the net and I set this options:
      uncheck Provide power to target and Power off target ....
      Shift frequency --> 31 (lower value)
      Delay after Reset... --> 100mSec
      check Enable logging (but I don't know where can I read the log..)

      Best regards

  • Greetings,

    The logging is in the console window.

    If you already have the DSC board powered via external power, then it is wise not to provide power to target via the multilink FX.

    After you compile your code with your source code, try using our PROG software for DSC devices. PROG DSC is one of our rare free software we provide:
    http://www.pemicro.com/products/product_viewDetails.cfm?product_id=15320158

    Grab the ELF file from your workspace and try programming it using our tools. If it passes, then we know that something in the project settings or debug settings are causing the problem. Our PROG tool just simply programs the ELF file and does not attempt to debug it. Try programming multiple times in PROG DSC for good measure.


    Takao Yamada

  • Hello Takao,
    I tested PROGDSC. With this FLASH PROGRAMMER I'm be able to put my .ELF file inside the DSC.

    I done 5 times this operations:
    - Erase Module
    - Program Module
    - Verify Module

    I obtained 0 errors.

    Now. It seem:
    -> Elf file is OK
    -> Multilink FX is OK
    -> My board is OK (but I worked fine with USB TAP)
    -> I can't debug with CODEWARRIOR....

    Can you solve it?

    Thank you very much
    Arcangelo

  • Hello Takao,
    I done several test and now I can fully debug my application.
    I find a very strange condition and I like to know what do you think about it.

    This is a little part of my original code:

    - - - -
    const unsigned char SwVer[]="00.01";   

    void CopySub(unsigned char *Str, unsigned char *numCar)
    {
    unsigned char gg;

    *numCar=gg=0;

    while (SwVer[gg])      
       {
       *Str = SwVer[gg++];
       Str++;
       (*numCar)++;
       }      

    return;
    }

    - - - -

    CopySub simply copy a const string in another string.
    If I compile this code it's ok and I can program and run this code.
    I can debug this code with USB TAP.
    But I'm not be able to debug it with MULTILINK FX.
    Running the debugger it returns this error code:
    "Failed to resume target process. GDI Procotol fatal error: : An error occurred while trying to read memory"

    SOLUTION:
    If I change first line in this way:
    unsigned char SwVer[]="00.01";    //SwVer[] it's not CONST STRING!!

    I'm be able to fully debug my program.....


    - - - - -


    What do you think about it?
    Do you think this is a bug problem?
    Where? In the CODEWARRIOR IDE or in the Multilink fx development interface?


    Best regards
    Arcangelo

  • Greetings,

    This is odd and I have never heard of such problem. Could you go to Support page -> Support requests and could you share your source code? Or portions of your source code that can compile so that we can replicate and look into this?


    Takao Yamada

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement