Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

Please accept the use of cookies on our site

At PEmicro we use web browser cookies in order to provide you with an enhanced experience and in order to be able to do things like shopping cart processing and identify you when you login to our website.

Click here to accept

search inside this forum
search inside all forums
USB is undetected in CodeWarrior 2.7/2.8 although I want to debug TRK-MPC5634M.
. Feb 23, 2016 at 08:36 PM (20:36 hours)
Staff: Takao Y.

  • Dear All,

    I bought TRK-MPC5634M and I'm trying to debug using Freescale CodeWarrior 2.7 or 2.8(OS is Windows7 professional) via USB cable included in the StarterTRAK, but the following error occurs on the PEMICRO Connection Manager when the debug button is pushed, so I can't debug TRK-MPC5634M.

    Interface: USB Multilink, Embedded Multilink, or Embedded OSBDM
    Port: Undetected. Disconnect/Connect USB cable. Click Refresh List.

    Although I clicked the refresh list, then [FAQ #29] appears and I tried the solution, but the same error still occurs.

    In device manager, USB is recognized and I could update firmware version using firmware_updater_install.exe.

    I wonder I have to buy Multilink or Cyclone to debug using CodeWarrior or are there any solutions?

    Thanks in advace.


  • Greetings,

    Codewarrior should support the embedded multilink on your TRK board. I am not familiar with CW 2.7/2.8, but I am very familiar with CW 2.10, which most customers are using for PPC NEXUS devices. I think maybe you need to update your software to the latest version and see if you have better luck. You may need to check NXP/Freescale's website for the latest version.

    Takao Yamada

    • Dear Mr. Yamada,

      Thank you for your reply.

      Thanks to you, I'm now able to debug by using CW 2.10.

Add comment

   Want to comment? Please login or create a new PEMicro account.

© 2018 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement